Lightroom 4: Won't load Thumbnails except what is onscreen

  • 2
  • Question
  • Updated 6 years ago
  • (Edited)
In lightroom 4 it wont load any thumbnails except what is on the screen. So if I have a folder with a ton of images trying to sift through and find them is almost impossible. I should be able to just click on a folder and all of the images should load constantly having to scroll the monitor down to load the thumbnails is absurd!!
Photo of seth holtzman

seth holtzman

  • 12 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 2
Photo of brian brains

brian brains

  • 69 Posts
  • 5 Reply Likes
Yes, it is infuriating.!!!

As soon as you select the first file in a folder, LR should build a thumbnail cache for the whole folder there and then and ensure the cache is used the next time you visit. But it doesn't. LR3 didn't either.
Photo of TK

TK

  • 531 Posts
  • 110 Reply Likes
This is not a question. People will debate whether it should be posted as a problem report or a feature request, but either is better than a question.
Photo of seth holtzman

seth holtzman

  • 12 Posts
  • 0 Reply Likes
Ok then,

Here's a question. Who the heck am I supposed to ask to request this as an update, let them know it's a problem, give feedback? Lightroom is a terrific program but this is such a simple thing that creates a huge backlog!
Photo of brian brains

brian brains

  • 69 Posts
  • 5 Reply Likes
Here here. No matter what preferences I set, changing folders in library view makes me wait ages whilst thumbs are either redrawn or pulled from some obscure cache. Either way it is too slow!
Photo of seth holtzman

seth holtzman

  • 12 Posts
  • 0 Reply Likes
I would love to leave them feedback. do you happen to know a good place to do this? I can't believe no one complained about this!
Photo of seth holtzman

seth holtzman

  • 12 Posts
  • 0 Reply Likes
I would love to leave them feedback. do you happen to know a good place to do this? I can't believe no one complained about this!