The Text Tool Not Allowing Me Scrolling Through Fonts Using The Arrow Keys On My Keyboard

  • 1
  • Problem
  • Updated 2 years ago
I made a quick video about this:
https://youtu.be/XlBxKbAJk9M

Basically, instead of me being able to scroll through the many fonts with the arrow keys, it jumps back to the fonts I already used. Very annoying.

Is there a fix for this?
Photo of Alexandra Giamanco

Alexandra Giamanco

  • 65 Posts
  • 8 Reply Likes
  • frustrated

Posted 2 years ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Howdy Alexandra,

What you're running into is the conflation of two features.  There is a feature we added two years ago (?) allowing users to arrow through their font list and preview it on-screen.  In the latest release, we now put the top five last used fonts at the top of your font list.  And what you're seeing as a bug, is these two working together.  Let me illustrate...

Do what you did in your video, but this time open your font dropdown.  You'll see that when you arrow down, you go through your last five fonts, regardless of alphabetical order, and THEN you hit the "regular" fonts sorted by writing system and then sorted alphabetically.  Does that make sense?

Thanks,
David
Photo of Alexandra Giamanco

Alexandra Giamanco

  • 65 Posts
  • 8 Reply Likes
Hi David,

Ok. I understand that, but I am not looking to repeat a font at any time. And if I am working on a document that needs more images with the same font, I usually just type it in that box + hit enter.  Its faster. 

Can you please restore it to where it doesn't show the last used unless we chose to see them in the preferences somewhere? I am asking because I have hundreds of fonts, just like I have hundreds of brushes, so this was a really easy way to sort/scroll through them. Matter of fact I so wish I could use those keyboard arrow keys to scroll through the brushes too.

The way it is now its annoying because I could open up the fonts, scroll using the scroll bar down to the one I want to use, and then after I chose it, it jumps back to the the last ones I used....so it is making me waste time, not to mention it is visually very annoying for someone like me who can only see out of one eye.

Please help put this back. Thank you.
(Edited)
Photo of Vinod Balakrishnan

Vinod Balakrishnan

  • 11 Posts
  • 8 Reply Likes
Can you turn off the "Missing Glyph Protection" from the Photoshop Type Preference and try out ( Menu: Photoshop CC/Preference/Type)  The newly selecting font may not have all the needed glyphs for the characters in the selection.
Photo of Alexandra Giamanco

Alexandra Giamanco

  • 65 Posts
  • 8 Reply Likes
That helped it seems. I just tried it, and I was able to put my cursor in the font name box and then use the arrow keys to scroll.

Thank you. :)
Photo of Alexandra Giamanco

Alexandra Giamanco

  • 65 Posts
  • 8 Reply Likes
Nevermind! It's doing it again after I unchecked that. This is VERY ANNOYING! Please STOP it from doing this; I literally cannot get my work done! 
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Hi Alexandra,

You have "Missing Glyph Protection" turned off and you are using your arrow keys to change fonts on a run of text that has no unusual characters, correct?

Would you be willing to send us the file and/or do a web-hosted screenshare with you?  I am not seeing what you're describing and don't quite follow the workflow problems that you're having.  Seeing the issue live should help.

Thanks,
David