Photoshop CS5: The file is not compatible with this version of phoshop

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
i use adobe photoshop cs5 - and recently saved a file, but after 2
minutes tried to open , buy it sais the file is not compatible with this version of phoshop
Photo of ehsan goldan

ehsan goldan

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
Did you accidentally save a JPEG file with TIFF as the extension?