Photoshop: The dreaded Pen Tool lag issue on Windows

  • 1
  • Problem
  • Updated 1 month ago
  • (Edited)

So yeah, I guess this is a known issue by now, even though a rare one: Seemingly out of nowhere Photoshops Pen tool started to lag for about a second on creating anchor points . If I want to use premade shapes like the ellipse tool it can even take up to 10 seconds (even when the ellipse is rendered and I am just doing a transform on it or move it around.

I do not experience any other issues at all (other than V.2017 is a bit slow on closing when I end it but i could not care less).

Before I go into a little bit of history on the issue, here are some things I noticed that other Users did not seem to mention anywhere:
- I can click and hold and manipulate the anchor point through that with no lag at all. It ery much appears that rendering the effect on the vector is causing the issue (filling the shape or contour).
- If I dont use it with the shape setting but in the path setting directly on some random layer I dont get a lag. However as soon as the path is on a shape layer it starts to lag again.
- looking at the path settings, they also take forever to update changes (the properties tab that is usually next to the layer tab, not the horizontal toolbar)

Now on to the history bit:
- I am running Win7 64bit, 8 gigs Ram, an i5 and a GTX660. Not exactly state of the art but seeing the other posts on the issue it does seem to hit pretty randomly.
- I am using the german version (and actually no clue how to switch that. Sorry for the Grman sys info)
- I was using V.2015 till a few days ago when the problem first started.
- There were some Windows updates around that time but the other Users reporting the issue are sometimes years apart and use different versions of Windows at times. So I guess it could be some driver thing. Anyways...
- I am using Quixel as my main third party plug in to work on normal maps and textures. I uninstalled it and tested it, no luck.
- Then I updated to V.2017, still no change.
- I updated my GPU and Tablet (Wacom Cintiq) drivers, nope.
- Windows Pen and Touch is already disabled.
- I started Photoshop with plugins idsabled, nope.
- Reset first the tool and then the factory settings, nope.
- Disabled Gestures, nope.
- Amped up RAM usage to a bigger percentage, lowered the undo states, set the Cache to 4, nope.
- Did set the drawing mode inside the Advanced GPU performance settings to Basic and deactivated OpenCL... THAT DID SOMETHING! It reduced the lag about half. It is still annoying as hell.
- Turning GPU completely off did not do anything.
- My mouse is generic so that does not do anything either.
- I think I experimented with something else but not sure what that was, only that it did not work, oh well...

I have a pastebin of my System Info here:

Would it help if I created a full process dump through the task manager and send it over via WeTransfer or other means?

I would love if this issue can be resolved, even a workaround would be nice. In the meantime I will switch to another application for my pen tool needs. (though I really like to use it in combination with Quixel and well, no Quixel in InDesign, Scribus, GIMP or SAE and making a design in another program and moving it to photoshop for every little thing gets really cumbersome when your forte is techy scifi stuff)
Photo of David Satzinger

David Satzinger

  • 2 Posts
  • 0 Reply Likes
  • confused and frustrated. Want to cooperate on solving this issue!

Posted 11 months ago

  • 1
Photo of David Satzinger

David Satzinger

  • 2 Posts
  • 0 Reply Likes
Oh yeah the other stuff I forgot:
- Deactivated Wacom drivers
- Did this thing I have seen in another thread where you set the tool to align with the canvas
- I could dust off my old intuos and check if there is no issue with a pen like some others are reporting but then again using my Cintiq should not make a difference.

And yeah, that I need to wait almost 10 seconds if I use the ellipsoid or other shape tools is the most interesting effect. It is almost like it cant load the settings/properties or render the changes fast enough to the canvas.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13621 Posts
  • 1541 Reply Likes
Hi David, yes process dump may help our engineers understand what's going wrong.
Photo of Igor Kurylak

Igor Kurylak

  • 2 Posts
  • 0 Reply Likes
Any news on that? Have the same issue with Intos 3 - have you fixed the problem?
Photo of Gareth Bowen

Gareth Bowen

  • 1 Post
  • 0 Reply Likes
Same... still lags any update on this?
Photo of Igor Kurylak

Igor Kurylak

  • 2 Posts
  • 0 Reply Likes
Try to instal previous version of driversĀ 
Windows - Driver 6.3.11-4a - IMO it's better but still not perfect. Lag is less and comfort of work is better still. Maybe the key is to experiment with different drivers version.