Photoshop CS6: Text Layers re-written from some ancient cache

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Hi Guys,

here's the issue.

When editing a text layer with the type tool, without pasting or anything, just entering the editing of the layer, Photoshop somehow pastes some cache'd text. Mind you - this isn't text that would have even been entered during the editing session.

Please take a look at the video of this bug in action.

http://youtu.be/ureQYxlsp6M

So instead of editing, sometimes, the text layer just pastes whatever from the cache.
This exact thing also happens, if you convert the group holding the layers to a Smart Object.

I can't figure out what happens that makes the layer affected or how to circumvent.
The only way I go around this is copying one of the layers that appear unaffected by this cache thing and editing them again, however, it does re-occur at some point after saving.

Please help, this is a really obnoxious bug.

I'm on Photoshop CS6 13.0.4 x64 on OSX 10.8.4 right now, but this has been happening to me consistently for about a year and I've been updating.
In fact I just updated to 13.0.5 x64 and still no cigar.
Photo of Octop

Octop

  • 27 Posts
  • 4 Reply Likes

Posted 5 years ago

  • 1
Photo of David

David, Official Rep

  • 2721 Posts
  • 373 Reply Likes
Official Response
Howdy Aleks,

The problem in Photoshop is now fixed.

If you're using the latest version of CS6 or CC, you will NOT have this problem reappear unless you open a file that's already been corrupted. The problem can only move to a new file if you move text with the problem from one file to another via copy/paste or drag/drop. So, if you create a new file using the latest version, you should be totally golden.

Sorry for the problem, but at least the solution should be bullet-proof.

Thanks,
David