text tool - Lorem Ipsum text doesn't disappear

  • 2
  • Problem
  • Updated 4 weeks ago
Version 21.2 Mac. When clicking to add line or dragging to add paragraph, the Lorem Ipsum placeholder text does not disappear when you begin typing.  The new text appears under the placeholder text.  The appearance is similar to when you place one text layer over another.   
Photo of Michael Burton

Michael Burton

  • 3 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 2
Photo of Keith Anderson

Keith Anderson

  • 64 Posts
  • 23 Reply Likes

It might just be a dexterity problem. 

I encountered this behaviour often when I first began entering text, and many of the details are significantly different from what Word might do. 

The benefit of the mouse is that it is easy to use and usually intuitive, but when placing and editing text there are many things we might want to do and Photoshop needs us to position the cursor rather precisely to work out what we mean. 


For example, it took me several tries, and quite a lot of rude words, to discover that to move text, it is necessary to Left click within the text to tell Photoshop I want to do something, and then move the cursor enough pixels away from the text for it to know that I want to move the existing text, not insert something into it or at the end of it.  How big is enough?  Photoshop will tell you by changing the cursor from an I beam to a four cornered star almost identical to the Move tool used to move other things that you might want to move.  Once you have that cursor, the normal hold and drag behaviour will work, or should work. 


Another reason for the unexpected Lorum Ipsum display is that your first click was not sufficiently "IN" the existing text for Photoshop to work out that you want to do something with this text and don't want to insert new text.  The most common difficulty is when you want to add text at the end of your existing text and/or create a new line.  You need to Left click very close to the end of the last character to tell Photoshop what you want to do and that you don't want to insert new text really, really close to the text you already have.


Oh.  Another trap I fall into is that I forget to click the tick at the top of the screen to tell Photoshop that I've done what I wanted to with or to this text, and my next click will be for different text, possibly new text.  That also invites Lorem Ipsum to gate crash when not wanted. 

Oh.  And another counter intuitive surprise that you might encounter if you are doing something like entering place names on a map is that you'll end up with a lot of layers: one for every placename.  In this case you might want to make a Group and put them all in that to keep them tidy. 

I still mutter rude words quite often when using Photoshop, but if you persevere, you'll use them less often.



(Edited)
Photo of Michael Burton

Michael Burton

  • 3 Posts
  • 0 Reply Likes
thanks for your thoughtful reply Keith however I should add that I've been using Photoshop for over 20 years.  I'm not a NOOB.  Here's the issue. Click to type>place holder text stays while you type>move type out of way>turn visibility of background layer off/on> placeholder text disappears.   It's a bug or I've gone crazy.  Here's a 20 second clip:  https://youtu.be/rQ2HE_y6Hn8
Photo of Keith Anderson

Keith Anderson

  • 64 Posts
  • 23 Reply Likes
Hello Michael,


Sorry my help wasn't helpful. 
Weirdly, Lorem Ipsum behaves itself for me.
Drat.  I hope I haven't spoken too soon.

I think I'm using the latest update.
They arrive so frequently, I'm never certain what version I'm using today.
With luck, not necessarily good luck, someone else will be experiencing this problem and have a better answer. 
Photo of Michael Burton

Michael Burton

  • 3 Posts
  • 0 Reply Likes
I figured this out.  Should have know!  Preferences> Performance> uncheck Legacy compositing...  https://youtu.be/Gih3q7iYjvM