Text tool becomes laggy with GPU acelleration

  • 1
  • Problem
  • Updated 2 years ago
I just noticed that the more text I write the slower, less responsive the text selection and edit font becomes. If I paste in the entire Lorum Epsum text that Photoshop provides and want to work with the text its almost impossible. But If I turn off Graphic Acceleration in Photoshop it becomes a lot more responsive.
I'm using Photoshop CC 2017 with Windows 10 and my GPU is an Nvidia GTX 1080 with the latest drivers. 

Anything I can do to fix this while still using the GPU accelerations? 
PS! I have also turned of Font Preview and scanned my font library with a Font Doctor, it doesn't help, I believe its a GPU issue within Photoshop. 
Photo of joachim barrum

joachim barrum

  • 119 Posts
  • 33 Reply Likes
  • frustrated

Posted 2 years ago

  • 1
Photo of Adam Jerugim

Adam Jerugim, Employee

  • 201 Posts
  • 89 Reply Likes
Try this... 

1.  Go to Windows Settings

2.  Choose Update and Security

3.  Choose Windows Defender

4.  From the Windows Defender Preferences look for 'Exclusions' and click on 'Add an exclusion'

5.  On the following page, select 'Processes' and then click on the 'Exclude a .exe, .com, or .scr process'

6.  In that field type the following:  Photoshop.exe

7.  then click OK

8.  Re-launch Photoshop CC 2017

 

Is performance better with this change?


Thanks,

Adam

Photo of joachim barrum

joachim barrum

  • 119 Posts
  • 33 Reply Likes
Hello thanks. But, that didn't help anything. It lags just as much