Photoshop: Text is more transparent than everything else with same opacity setting

  • 1
  • Problem
  • Updated 8 months ago
  • Not a Problem
  • (Edited)
Here is a Text object (right) and the same object flattened to a pixel layer (left).
Both have 70% opacity (same with fill amount) and the text object appears lighter.
Both are pitch black from the beginning.
The color picker shows 30% brightness on the left X as expected, but the right X is 45%

So text appears to be always lighter which I believe is wrong. Because say you merge a folder in which you have text and other elements then this would change the outcome.
For example if I merge both layers togehter, the right X becomes just as the elft one.

Something else I found out, when I put the text object in a folder (100%) and I turn the folder to 70% then the result is correct (like the left X).

Info:
Adobe Photoshop Version: 19.1.5 20180604.r.346 2018/06/04: 1175273  x64
Operating System: Windows 10 64-bit
Version: 10 or greater 10.0.17763.1
Photo of McDev

McDev

  • 2 Posts
  • 0 Reply Likes

Posted 8 months ago

  • 1
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 880 Posts
  • 221 Reply Likes
Check your color settings in PS. Text blending has its separated rules.
Photo of David

David, Official Rep

  • 3286 Posts
  • 525 Reply Likes
Howdy,

Jaroslav is right.  Text is treated differently with its own Gamma value due to compositing.  In the past, when things were the same, we got MANY reports that text was too dark, particularly when it was colored.  As I recall, this is an issue with certain fonts and not others, with the setting being the best happy-median for the widest audience.

Hope that helps,
David
Photo of McDev

McDev

  • 2 Posts
  • 0 Reply Likes
Alright thank you both. In general this shouldn't be an issue, in this case I was using text to make an icon basically so it stuck out next to others. But its fine once I know it or as I found I might put it in a folder (which well, is still not consistent though...).
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 866 Posts
  • 214 Reply Likes
I think you could disable that difference for text. In color settings.
Photo of David

David, Official Rep

  • 3221 Posts
  • 513 Reply Likes
Set your Blend Text Colors Using Gamma to 1.0 under Edit > Color Settings and Advanced Controls at the bottom right, or just turn this function off entirely.