Tethering issues EOS-1Dx / C in Lightroom 2015.9

  • 1
  • Problem
  • Updated 1 year ago
Lightroom has always provided robust tethering support for EOS cameras. The 2015.9 update appears to have broken this. In a couple of hours of use, I saw a broad range of issues:

Connection issues;  files imported at least 1 stop darker than the camera file (no Highlight TP); blank files appearing in LR when the capture file existed on the card;  beachball when trying to navigate files.

I gather from Ian Lyons that a new Canon tether SDK is in use. Is anyone else seeing issues?

Specifics: EOS-1Dc (effectively 1-Dx) / LR 2015.9 / MacOS 10.12.3
Photo of NWB

NWB

  • 40 Posts
  • 8 Reply Likes

Posted 1 year ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1417 Posts
  • 437 Reply Likes
Does it work fine in Lr 2015.8? As far as I know, there were no tethering related changes in Lr 2015.9. The new Canon SDK update was part of the Lr 2015.8.
Photo of NWB

NWB

  • 40 Posts
  • 8 Reply Likes
Thanks Simon - I experienced the UI issues with  2015.8 very early on, so I never got the chance to test tethering before reverting to 2015.7. Some of the connectivity behaviour I was seeing in 2015.9 was consistent with Canon SDK problems I have seen before in other apps (blank files, camera not seen, camera freeze)  but the beachballs continued after restarting the app and without reconnecting the camera.

One thought: I'm used to seeing a discrepancy between camera preview (jpg) and LR capture, but the difference yesterday was much more marked and I was consciously overexposing to compensate. 

Here is a question - is it possible for two versions of LR to exist (not run together) on a Mac if named differently?  I used to do this with multiple versions of C1 quite happily when beta testing
(Edited)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1417 Posts
  • 437 Reply Likes
Is the preview difference specific to tether or do you see that in your normal photo shooting? Do you have custom default develop settings setup for the camera? Have you enabled some camera specific proprietary features, such as dynamic lighting on some of those cameras, to account for the difference?

>Is it possible for two versions of LR to exist (not run together) on a Mac if named differently? 
Yes. 
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1417 Posts
  • 437 Reply Likes
Have you also checked if your camera's firmware is up-to-date?
(Edited)
Photo of NWB

NWB

  • 40 Posts
  • 8 Reply Likes
Yes, everything up to date. Tether yielded darker images - no lighting settings.
I'l reinstall 2015.9 as well when I have time to test.