Lightroom: Tethered capture runtime error (Win 7/Home)

  • 1
  • Problem
  • Updated 7 years ago
  • (Edited)
I am getting the following runtime error when attempting to shoot tethered to Lightroom 4.1:
Unexpected error performing command:?:0: attempt to perform arithmetic on a nil value
The error is generated when attempting to start tethered capture, i.e. File/Tethered capture/Start Tethered Capture. No dialogue box is opened just this popup error message.
System Info that may be of use is as follows:
Lightroom version: 4.1 [829322]
Operating system: Windows 7 Home Premium Edition
Version: 6.1 [7601]
Application architecture: x64
System architecture: x64
Physical processor count: 8
Processor speed: 1.5 GHz
Built-in memory: 8125.8 MB
Real memory available to Lightroom: 8125.8 MB
Real memory used by Lightroom: 1602.3 MB (19.7%)
Virtual memory used by Lightroom: 1590.5 M
Memory cache size: 108.1 MB
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1600x900
Application folder: C:\Program Files\Adobe\Adobe Photoshop Lightroom 4.1
Library Path: C:\Users\Dave\Pictures\Lightroom\Lightroom 4 Catalog.lrcat
Settings Folder: C:\Users\Dave\AppData\Roaming\Adobe\Lightroom

Camera is a Canon 5D Mark ii, firmware 2.0.9
Lightroom location: C:\Program Files\Adobe\Adobe Photoshop Lightroom 4.1
Catalogue location: C:\Users\Dave\Pictures\Lightroom
Imported photos: C:\Users\Dave\Pictures\Auto Import
Destination: C:\Users\Dave\Pictures\Auto Import Photos
Tethering using the Canon Eos Utility and associated software works perfectly.
Hope you can help,
Photo of David Taylor

David Taylor

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15276 Posts
  • 2200 Reply Likes
We haven't seen this issue. Have you tried all the troubleshooting steps in this document?

Troubleshoot tethered capture | Lightroom 4, 3:
Photo of David Taylor

David Taylor

  • 2 Posts
  • 0 Reply Likes
Thanks Jeff for your quick reply. I have tried all of the suggestions at the web site you gave but to no avail.

Some further information. The laptop I am using is an HP Pavilion dv7 and I wouldn't say that it is the most stable machine I have possessed, blue screens and occasional loss of some of the USB ports which may be/may not be responsible.

I loaded Lightroom 4 yesterday on another machine this time running a preview copy of Windows 8. The result was positive, tethering worked. So today I loaded Windows 8 on the Pavilion but got the same problem.

I have turned off all processes and services using msconfig it order to reduce potential conflict but have not got a solution. It is increasing looking like a machine specific error. The fact that a search the internet has not thrown up a single reference to this error adds to this conclusion.

Looks like a line by line debug to see where (and why) this error is occurring is the only solution. Not necessarily a bad thing in order to capture this runtime error and add to the robustness of the software, but for a single instance? In the meantime I will have to continue to use Eos Utilities and import later.

I have not given up though!

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15259 Posts
  • 2198 Reply Likes
OK. Yeah. In talking with the QE for the tether feature, he said the Canon 5D Mark II is one of the most popular and most tested cameras and he hadn't heard of wide spread problems with tethering this camera. I would look at system specific issues - and it sounds like what you're seeing.