Lightroom Classic: Tether does not detect cameras on new Catalina macOS 10.15.2 (works in 10.15.1)

  • 2
  • Problem
  • Updated 7 months ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Lightroom Classic: Tethering from Canon cameras doesn't work on macOS Catalina 10.15.2

Hi guys, in the first day of photoshoot with my new MacBook pro 2019 Catalina 16 inch I tethered my Canon 5d Mark III with Lightroom Classic last version and it's start working good, but after when my camera go in sleep mode, the tethering never happens again. I did all suggestions. I was update My Camera, and was update Lightroom version., turn on and off. I was switched different USB cables, delete everything from memory card . I use it with memory and without memory card. And it still doesn't work. I tried to solve this problem around four days already. Everything working on my Windows computer. So the problem is not in the camera or cord. Please help me to fix this problem thank you.
Photo of Irina Stelmakh

Irina Stelmakh

  • 1 Post
  • 0 Reply Likes

Posted 7 months ago

  • 2
Photo of G0apher

G0apher, Employee

  • 110 Posts
  • 29 Reply Likes
Could you please confirm the macOS Version in your system? (Is auto update turned ON for receiving the OS updates?)

There is a known issue with Canon cameras and Tethering with Lightroom Classic, with macOS 10.15.2. See https://helpx.adobe.com/lightroom-classic/kb/macos-catalina-compatibility.html#Knowncompatibilityissues
Photo of ronald stoops

ronald stoops

  • 1 Post
  • 0 Reply Likes
same here waiting for upgrades
Photo of David Converse

David Converse

  • 941 Posts
  • 275 Reply Likes
Have you tried Canon Utility?
Photo of Mildre Torres

Mildre Torres

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom Classic: Tether capture not working with macOS Catalina.

I have the current version of Catalina on my Mac 10.15.2, I have the current version of Lightroom classic, and the current version of plug-ins / firmware for my pentax645z.  I try to tether capture but I can't.  It sees I'm using a Pentax 645z but it's not showing the shutter or f-stop.  Any ideas?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7627 Posts
  • 1739 Reply Likes
Photo of Art M.

Art M.

  • 99 Posts
  • 21 Reply Likes
Capture One is now available with a new update that fixes the tethering problem introduced by Mac 10.15.2. Hopefully Adobe will soon issue a similar fix for Lightroom. Noteworthy is that Phase One, the makers of Capture One, issued a warning to its clients to NOT update to 10.15.2 many days ago. (I use Photoshop and Lightroom and Capture One all for different purposes in my photography workflow.)

This conversation is no longer open for comments or replies.