Lightroom Classic: Tether capture not working with macOS Catalina

  • 1
  • Question
  • Updated 7 months ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Lightroom Classic: Tether does not detect cameras on new Catalina macOS 10.15.2 (works in 10.15.1)

I have the current version of Catalina on my Mac 10.15.2, I have the current version of Lightroom classic, and the current version of plug-ins / firmware for my pentax645z.  I try to tether capture but I can't.  It sees I'm using a Pentax 645z but it's not showing the shutter or f-stop.  Any ideas?
Photo of Mildre Torres

Mildre Torres

  • 1 Post
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7585 Posts
  • 1730 Reply Likes
Likely it is related to the last item on this page: https://helpx.adobe.com/lightroom-classic/kb/macos-catalina-compatibility.html. Hopefully the next Catalina update will restore functionality. 
Photo of Art M.

Art M.

  • 99 Posts
  • 21 Reply Likes
Perhaps this is news to Adobe support but I have heard from various people that Mac OS 10.15.2 broke live camera tethering. It worked fine in 10.15.1. Phase One corporation, the makers of editing software “Capture One” , sent out an alert days ago warning its clients to not upgrade to 10.15.2. Adobe probably needs to work with Apple to resolve this. There is a rumor that someone at Apple changed the protocol for a necessary API this is unconfirmed. Anyway I am still on 10.15.1 and tethering fine to Capture One. Have never tried tethering with Lightroom so cannot provide direct feedback from personal experience.

This conversation is no longer open for comments or replies.