Lightroom CC: Tabbing through metadata fields

  • 1
  • Problem
  • Updated 9 months ago
  • (Edited)
A small bug to be fixed: 

1. In the City metadata field, I type in a value (e.g. London).
2. I tab to the State / Province metadata field. 
3. LR CC focuses on the State / Province metadata field and then, a second later, will lose focus on this field. 
4. I have to manually click into the State / Province metadata field to be able to enter a value.
Photo of kintarasan

kintarasan

  • 17 Posts
  • 6 Reply Likes

Posted 9 months ago

  • 1
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 222 Reply Likes
I was not able to reproduce that behavior on my Mac running 10.13.2

What operating system are you using and are you using the current 1.1 version of LrCC?

As a start you could try resetting preferences. Just hold down Alt / Shift (Win) or Option / Shift (Mac) while opening the app from the Creative Cloud desktop app then choose "Reset Preferences" 

Let me know if that helps.

Rick
Photo of kintarasan

kintarasan

  • 17 Posts
  • 5 Reply Likes
@Rick: I'm on Mac High Sierra (v10.13.2) and am using v1.1 of LR CC.

Have uploaded a short video (sorry for the shakiness) showing the behaviour described above.

https://we.tl/XK1COfySEZ

It looks like after I tab out of the City metadata field it loses focus to refresh the map location. The City metadata field has to be blank when it's clicked on to trigger this issue. 

I'm the process of uploading photos at the moment will try resetting preferences in case that does fix the issue. 

Hope that helps!
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 335 Reply Likes
When you do this, watch the upper left-hand corner of the interface near the identity plate. Do you have a progress bar working there when this is happening? If you wait until the progress bar is complete do you still have the problem of the field switching back?
 
Photo of kintarasan

kintarasan

  • 17 Posts
  • 5 Reply Likes
@Rikk: This is on LR CC not Classic so there's no identity plate. However, I take you point that this might be linked to the fact that I'm in the process of uploading images. Only 350 to go so when that's done I'll see if I can replicate the behaviour. 
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 335 Reply Likes
Curious to see what happens when you give it a pause to allow the in-process operation to complete. 
Photo of kintarasan

kintarasan

  • 17 Posts
  • 5 Reply Likes
Tried that. Unfortunately it doesn't regain focus on the State / Province field.
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 335 Reply Likes
I am not able to reproduce your behavior either - even with 37,000 images selected! 

One option to consider is to reset your Lightroom CC Preferences

Preference Corruption can cause strange behavior.  Hold down [Opt]+[Shift] while launching the Lightroom CC program. A message should appear to prompt you to reset your preferences. 

Does the behavior continue afterwards?
Photo of kintarasan

kintarasan

  • 17 Posts
  • 5 Reply Likes
Not sure why the number of images would be relevant. I can see this behaviour with just one photo selected. 

In any case, I reset the Lightroom CC preferences. The only difference is now it takes LR about 7 seconds to display the map to the location entered in the City field. The upside of the delay is that I can enter a value in the State / Province field before LR CC loses focus. 

From my perspective, LR CC should display the map and set it to the specified city in the background - without losing focus on the selected metadata field.
Photo of Monty

Monty

  • 107 Posts
  • 39 Reply Likes
This happens to me also!  I bit irritating 
Monty