LIGHTROOM 5: System requirements say my iMac 2.16 ghz with 4 GB ram Graphics ATI Radeon X1600 128 MB should run this program.

  • 1
  • Question
  • Updated 5 years ago
  • (Edited)
System requirements say my iMac 2.16 ghz with 4 GB ram Graphics ATI Radeon X1600 128 MB should run this program. (lightroom 5.2) also tried 5.3. Can you tell me why not? Not using any movies and only doing 40 slides. Help!!! Just bought this and need to return if this won't work. thanks! PS Not mad, just sad. I know there are way too many computer configs to solve everything.
Photo of John George

John George

  • 2 Posts
  • 0 Reply Likes
  • sad

Posted 5 years ago

  • 1
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 104 Reply Likes
Which version of Mac OS are you running?

What happens when you try to run Lightroom? Any error message?

Thanks,
Becky