Lightroom: Sync settings keyboard shortcut (CMD-shift-S) not working in LR 4.1?

  • 1
  • Problem
  • Updated 6 years ago
  • Not a Problem
  • (Edited)
Is anyone else having this problem? I've upgraded to LR 4.1 on my production machine (Mac Pro, OS 10.6.8), and my most-used keyboard shortcut for LR isn't working - CMD-shift-S to sync settings across multiple images. It worked fine before I upgraded this computer to LR 4 / CS6.

I select my changed image, then the ones I want to apply the changes to per normal, but I get an error beep when I hit CMD-shift-S. I can see the shortcut listed in the pull-down menus and it's not grayed out or anything. The only way I can get sync settings to work is by wading through the menus, which is a drag considering the comparative ease of a keyboard shortcut that I can see but can't use.

I've already looked in the system prefs for conflicting keyboard shortcuts and found none; there were no application-specific custom shortcuts at all, either. I even tried adding an application-specific shortcut in system prefs but that didn't work, either.

Don't want to go through the potential peril of reinstalling the entire app as a mere troubleshooting step, so I'm hoping someone here has a solution to this frustrating issue.

Thanks!
Photo of Francis Zera

Francis Zera

  • 6 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3813 Posts
  • 1263 Reply Likes
If you sync without the keyboard shortcut (i.e. using the menu command) does it work?

If not, have you ever had a secondary monitor attached? I've seen cases like this, where the dialog was coming up on a monitor that was turned off.

I wouldn't worry about reinstalling - worst case scenario, trashing the preferences file should do the trick.
Photo of Francis Zera

Francis Zera

  • 6 Posts
  • 0 Reply Likes
Thanks for responding. Syncing works via the menu command, yes.

I do use two monitors, and they're always active. I've used this same setup since LR was in beta, and the sync keyboard shortcut has worked until LR 4.1.

Trashing the prefs file solved the issue -- for one use. I tried using the shortcut a couple minutes later and it's not working again.

Issues like this are as frustrating as trying to track down an electrical issue in an English automobile.
Photo of Francis Zera

Francis Zera

  • 6 Posts
  • 0 Reply Likes
And now there's no shortcut visible in the pull-down menus. Where the shortcut used to be there's now a comma and an ellipsis, i.e., "Sync settings, ..."

If I select multiple images and right-click on one, the keyboard shortcut appears under the "develop settings" menu.

Strange things is that everything works great on my MacBook Air, but it's running Lion. Could this be a bug with LR 4.1 and Snow Leopard?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3813 Posts
  • 1263 Reply Likes
Weirder and weirder. Any chance of a screenshot? And when it did work, did it show correctly in the menu too?

The ones in the right-click I think are static, so let's ignore that one for a minute.

And just double check your system preferences again. The thing I've seen nick shortcuts most often are Services, so they'd be the first place I'd look.
Photo of Francis Zera

Francis Zera

  • 6 Posts
  • 0 Reply Likes
Victoria, you're a genius. There was indeed a conflicting shortcut in System Preferences/Keyboard/Services. It was from the ClamX anti-virus software I'd installed several months back and forgotten about.

The strange thing is that it never conflicted with LR3 or 4, only 4.1. I use LR almost daily, and cmd-shift-s is the shortcut I use most frequently, so I'd have definitely noticed the conflict.

In any case, I disabled the ClamX shortcut, rebooted the computer, and things seem to be working as expected.

Thanks for all the help — I really appreciate it.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3804 Posts
  • 1257 Reply Likes
Excellent, I'm really pleased to hear it.