Lightroom Classic: Sync images in Develop mode problems

  • 1
  • Problem
  • Updated 6 months ago
  • (Edited)
Hi community...

I'm using lightroom classic on a MacBook Pro (touch bar) late 2017 and I've noticed over the last few months that when I sync settings on images across the whole folder/library and move to the next image while the sync is happening, the next image does not render or change to the next image until the sync is complete. 

I just wanted to know if this was a known issue as I've tried searching for it online but I can only seem to find sync issues between lightroom and cloud. 

Thanks in advance for the help.
Photo of Manpreet Singh

Manpreet Singh

  • 1 Post
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of RICHARD CASSEL

RICHARD CASSEL

  • 32 Posts
  • 8 Reply Likes
Having a similar issue when exporting image to Photoshop. After making PS changes and saving, PS version of original image now appears in Lightroom. Problem is that PS changes disappear when LR is in develop mode, only appear in library mode. This is a big problem as I usually want to make additional changes in LR but literally cannot see the PS version of the image in develop mode.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2896 Posts
  • 1246 Reply Likes
Photoshop changes are ‘baked into’ the document. Pixels have changed. There is no way that Lightroom could not show these changes in some module and show them in another. Something else must be going on, for example you may be looking at the original instead of at the Photoshop version.
Photo of RICHARD CASSEL

RICHARD CASSEL

  • 32 Posts
  • 8 Reply Likes
Uh, no, there is a way. Lightroom is showing the original in develop mode but shows the Photoshop corrected version in Library mode. Assume this is a software bug.