Lightroom: Suddenly trouble importing photos

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
Suddenly I cannot import photos into Lightroom. When I try to import the source directory displays correctly in the left panel but no photos previews display in the main window. I've tried using different SD cards, different drives and photos from different cameras. I downgraded from Lightroom 5.4 to 5.3 without any change. I can't remember for sure if I upgraded my operating system when the problem started but I don't think so. I am operating OS X 10.9.3.
Photo of edward.schmidtt

edward.schmidtt

  • 8 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2656 Posts
  • 341 Reply Likes
If the problem started just after updating to 10.9.3, then Mavericks has hidden your Users folder and that confuses LR.

There is an iTunes update to fix the hidden folder problem.

http://www.macrumors.com/2014/05/16/a...
Photo of edward.schmidtt

edward.schmidtt

  • 8 Posts
  • 0 Reply Likes
My iTunes is up to date, version 11.2.1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2656 Posts
  • 341 Reply Likes
Does it work to Drag-and-Drop from that card's folder in Finder to the central area in LR Library? This is how I initiate all my LR imports on Windows. I am typically doing an Add import from the final location on the hard-drive rather than a Copy as DNG import, though.
Photo of edward.schmidtt

edward.schmidtt

  • 8 Posts
  • 0 Reply Likes
Thanks for getting back to me. Tried all the suggestions with no luck.
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 335 Reply Likes
A benign test would be to zotz your preference file and see if the problem disappears.

http://www.lightroomforums.net/showth...

Fixes some weird stuff sometimes.
Photo of edward.schmidtt

edward.schmidtt

  • 8 Posts
  • 0 Reply Likes
That worked! Thank you. I'm back in business!