Photoshop: Strange corruption issues using the new 'Place linked files' feature of CC

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
Hi There,

We're seeing some strange corruption issues (see attached) and are having trouble tracking down the source.

Example workflows which seem to create the issues:

Example #1.
- Open a file that contains placed links
- Place a photoshop file
- The placed image has a large transparent area (see left image attached)
- Open the original file and it looks transparent/blocky (see right image attached)

Example #2.
- Open a file that contains placed links
- Place a photoshop file
- The placed file looks transparent/blocky (see the right image attached)
- Open the original and it looks fine
- Re-save original
- Placed file updates and looks good
- But after file containing placed files is saved, they often look corrupt again

Workarounds:
- Don't save and quit PS ASAP
- Reopen PS and file
- Place linked files until it happens again

At the moment this is happening on a 2009 Mac Pro but not on a 2013 Macbook Pro and we've run:
- hard drive tests/repairs
- ram tests
- video memory tests

All tests passed.

The images are stored on a RAID 5 drive which we've also tested (as per above).

The files we're placing are between 300MB - 600MB and the master file we're placing into is around 1GB (with 12-13 placed files)

Does anyone have ideas on how best to eliminate potential issues and track down the source of the problem?

We've only seen this with files that are placed and have not experienced anything like this in the previous 20+ years of using Photoshop.

Any pointers in the right direction would be much appreciated.

Cheers

Ben

Photo of Ben

Ben

  • 7 Posts
  • 2 Reply Likes

Posted 5 years ago

  • 1
Photo of Ben

Ben

  • 7 Posts
  • 2 Reply Likes
Looks like the plugin "PSDRecover.plugin" fixed one of the files - not sure what is causing this sorry.