Lightroom mobile: Store locally does not work anymore (iOS)

  • 4
  • Problem
  • Updated 1 month ago
  • Solved
  • (Edited)
hi,

The "store locally" function on iOS seems to be not working anymore.

The only way to get the counter increasing is by manually "load" a picture by opening it.

I have enough space on my devices, rebooted the apps, devices and tried on different networks. Any others having this issue?

Kr,
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes

Posted 11 months ago

  • 4
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
Is it pulling in 0 images or is it stalling somewhere along the way?
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Pulling in 0 unless I manually open and load an image, then the counter increments. So if I want to download all the images of an album, I have tu load them all.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
I am not able to reproduce. I tried about a half dozen albums from 30 - 300 images each and it pulls them all down without having to manually manipulate.  Have you restarted your device?
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
I have, both app and both devices.
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Here’s a video of the issue. First a Speedtest just FYI (around 15 MB/s)

https://share.icloud.com/photos/0hJxE...
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
Thanks for the video.  I see you've been to Hraunfoss!

I tried duplicating your actions on my iPad and am not able to see what you are seeing. I am going to ask an engineer to step in here.
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
I have
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
* I have, it was awesome!
Photo of Guido Reule

Guido Reule, Employee

  • 74 Posts
  • 14 Reply Likes
Do you have "Only Download Smart Preview" - enable when you open up Lr Mobile settings -> Cloud Storage&Sync? Does this occur to all of your albums? - Lr Mobile QE
(Edited)
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
No, but it shouldn’t matter as the vast majority of my synced catalog is coming from Classic. It also fails with original files upload from iPad.
Photo of Troy Unverdruss

Troy Unverdruss

  • 11 Posts
  • 3 Reply Likes
I'm having the same issue actually after upgrading to 2 new devices and iOS 12. In my case, it runs for about half of an album (1081/2036) and then stalls. It actually appears to stall in the same place on both devices which also seems suspect. 

I tried to unmark "store locally", clear all caches, uninstalled LR, reinstalled and problem persists. 
Photo of Troy Unverdruss

Troy Unverdruss

  • 11 Posts
  • 3 Reply Likes
Also, I do have "download smart previews" selected.
Photo of Troy Unverdruss

Troy Unverdruss

  • 11 Posts
  • 3 Reply Likes
I've made a little progress, one of my other albums wasn't syncing correctly either, so I started there. I'm using Lightroom Classic on my Mac so I unchecked the "sync with cloud" option, then cleared my local cache on iOS and then re-enabled it on the Mac. When choosing "store locally" on iOS it worked... this fixed it for that album. Maybe this will work for you. Seemed to sync very fast so I doubt that Adobe is clearing your data from the cloud immediately but I can't be sure of course.

For the other album with 2000+ photos, this option didn't work for me, so what I've ended up doing is selecting all of the synced photos and then found a field that I hadn't stored any metadata in (yet). For me it was "Caption", I just typed in a "." and saved the change. This is forcing a re-sync of all my files so it's taking FOREVER but it looks like it might have gotten it unstuck. 1700 files to go... I'll post back if it works or not.
Photo of Antoine Hlmn

Antoine Hlmn

  • 572 Posts
  • 140 Reply Likes
Thanks for the advice :)

As I have many many folders to sync (yes, folders! bluntly duplicated to collections as folders don't sync), I will not try too much to mess with it. It seems to be clear it's a server/app issue so I'll just wait until the problem solves. Let's hope for un update soon as an engineer is looking at it :)
Photo of Troy Unverdruss

Troy Unverdruss

  • 11 Posts
  • 3 Reply Likes
Yea, so it didn't even fully work for me. It did fix a lot of the images, now I get to 2030/2036 but then it stalls forever again. Also seems like it has a queue, so I can't download other albums once it stalls out for one of them. 

Seems to be clearly a server/app sync issue, but since this is the album I'm trying to work on right now, it's really annoying! Hopefully they can fix it soon. 
Photo of Troy Unverdruss

Troy Unverdruss

  • 11 Posts
  • 3 Reply Likes
Seems there might have been something messed up about the collection itself, I created another collection with the same name but with a "2" added and then I started moving the photos from one collection to the other. All the syncing completed just fine in the new collection.

So if you're in a pinch, this might work for you as well. Also the process was extremely quick since it doesn't re-upload the files if they were already in the Adobe sync cloud.
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Up! Any fix on the roadmap?
(Edited)
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Could you please put my subscription on hold until this is solved ?
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Just for the record: I was on the plane lately and could not use the app I am paying for.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
I have pinged the team on this. My iPhone is experiencing the same issue today. 
Photo of Troy Unverdruss

Troy Unverdruss

  • 11 Posts
  • 3 Reply Likes
Not so nice that we have to wait until YOU personally have a problem for you to ping the team on our behalf when we've been waiting patiently for feedback over here for TWO MONTHS.
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Don’t take it bad, but does the issue needs to affect an Official Rep before it is taken seriously?

I had no reply from Ignacio nor on this forum since ages. Is thes really how Adobe treats it’s customrs? Is QC a known issue and will we ever get a Mea Culpa or will this continue forever? (Should I add: as long as the cash flows).

I don’t want want to be rude or whatsoever, but is this really a respectful way to treat customers?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
Antoine and Troy,

I understand and sympathize with you. We take every report seriously but it is really tough to fix something until we can successfully reproduce it. I've tried reproducing this many times but  unfortunately, it took until now for it to manifest for me.

We are working on it. Thank you for reporting and your patience.
Photo of Marcello Aurora

Marcello Aurora

  • 3 Posts
  • 0 Reply Likes
Good day! I am experiencing the same issue. I am not sure when it started, but likely it may be somehow connected to ios12 update.
I tried several times to reset the app as well as the whole cloud, but nothing worked.
I hope you'll find a solution soon.

Thanks.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
Update:

As a part of my testing on this bug, I resolved the issue on my two stuck devices (iPhone 7 & iPad Air II). Give this a try and let me know how it fares for you.

  1. Create (or use if you have one already) an additional Adobe ID.
  2. Make certain that your device is completely synced (do not attempt if not synced)
  3. Sign out of the device and wait a few minutes for the iOS background processes to complete.
  4. Sign in under the alternate ID.
  5. Sign out from the alternate ID.
  6. Sign in under your production ID.
  7. Allow the app to fully sync again
  8. Select an Album and set it to Store Locally
On both of my accounts and devices where this was stalled, it successfully synced and stored locally after following these steps.  Let me know if this works for you.
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
I just tried but it failed.
I even tried to remove the cached pictures on my iPad and the already stored pictures.
Nothing... and now I’ve lost what I had imported on my iPad! Because you know, that’s another workaround to have 1:1 on mobile... workaroundception isn’t maybe the most obtimal, in the end
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Tried one more time on iPad and on iPhone... same result
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
I've let the engineers know, Antoine.
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
There was a new version of LR but the problem still exists
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
Antoine,

A question from the engineers troubleshooting this issue.

Does this only occur in albums where you have a Tiff file which is also synced to Classic?

If you make an album with only raw or jpeg files will it store locally?
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Hi Rikk,

No, it occurs in every album, unfortunately.
I barley ever use TIFF (in return from photoshop) or jpeg (some screenshots are in png). I shoot almost exclusively in dng (Pentax) or proprietary raw (DxO).
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
Thanks
Photo of Troy Unverdruss

Troy Unverdruss

  • 11 Posts
  • 3 Reply Likes
I don’t use tiffs either
Photo of Troy Unverdruss

Troy Unverdruss

  • 11 Posts
  • 3 Reply Likes
Also if you read my above comments you’ll see that isn’t specific to the contents, but rather the folder itself. I moved all my images to a new folder and resynced and everything worked on the new folder even though the images are the same.
Photo of Marcello Aurora

Marcello Aurora

  • 3 Posts
  • 0 Reply Likes
Same for me, I don't use TIFF, but almost only RAW (formerly Nikon, now Sony).
However I noticed that importing photos through Lightroom CC (on an iMac computer), as sson as the import is finished and the pictures are available in the cloud, results in the iPhone starts storing locally. But it took few hours for a few pictures, so I interrupted the process. 
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
The team was able to repro and get a bug going. We should have this fixed in an upcoming release. Thanks for your patience.
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Awesome! I look forward to using LR again!
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Still nothing? It’s been 3 months now
Photo of Calum Macleod

Calum Macleod

  • 7 Posts
  • 0 Reply Likes
Unfortunately not working for me, been following this thread with interest, multiple trouble tickets with Adobe, countless hours with technical support, new software update yesterday, delete / reload Lightroom>......and still nothing works>..... will not download originals or smart previews using store locally.
Photo of Antoine Hlmn

Antoine Hlmn

  • 588 Posts
  • 143 Reply Likes
Hey Adobe ? What's going on with this bug?
Photo of Olivier_G

Olivier_G

  • 3 Posts
  • 1 Reply Like
I had this issue too on my iPad. The good news is that today's update (4.2.0) has solved it. It works great now! Thanks!
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5548 Posts
  • 1167 Reply Likes
Thanks for reporting Olivier. 
@Antoine, is yours working with the new update?
Photo of Antoine Hlmn

Antoine Hlmn

  • 484 Posts
  • 128 Reply Likes
Just tried and... yes! it finally works :D
Thanks Rikk!
(Edited)
Photo of Marcello Aurora

Marcello Aurora

  • 3 Posts
  • 0 Reply Likes
Also mine finally works! Thanks!
Photo of Calum Macleod

Calum Macleod

  • 7 Posts
  • 0 Reply Likes
Unfortunately not working for me, been following this thread with interest, multiple trouble tickets with Adobe, countless hours with technical support, new software update yesterday, delete / reload Lightroom>......and still nothing works>..... will not download originals or smart previews using store locally.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
This thread was about Albums partially downloading. It sounds like nothing will store locally on your device, Calum. Do I read that right? That would be a different issue. 

Can you provide: 

Device Model:
Mobile OS version:
Lightroom version: 
Free Space on device:
Number of images in your all Photos:
Status of sync (Cloud Icon)

Photo of Calum Macleod

Calum Macleod

  • 7 Posts
  • 0 Reply Likes
Thank for the follow up Rikk, much appreciated, no, I can partially download photos however it just hangs after a few hundred photos or so, the problem is the same as others are / were having. I can download each photo individually if required.

Details are -

Device modal - ipad gen 3, 12.9 MTJD2B/A
Mobile OS - 12.1.4
Lightroom version - v4.2.0
Free space on device - 357.89 GB
Number of images - 8290, mostly jpeg
Sync status- synced and backed up, although I have no albums configured for Store Locally right now

Let’s hope we can resolve, the bug has been with me for months and the iPad is my main device.

Kind regards
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5728 Posts
  • 1227 Reply Likes
Calum,

When I have an album stuck ( a very rare occurrence), normally it is one image in an unusual state. Changing a star rating on the image or a similar small change will usually unstick it.  Unfortunately it isn't always easy to determine the stuck image. Tiff's are the normal culprit.  Here's what I do.

  • Select the album that is not complete
  • Go into Loupe view (Info Mode)
  • Swipe through the images looking for Tiff files
  • Make a small metadata change to these 
  • Review the album status to see if images have started downloading for local storage. 
Photo of Calum Macleod

Calum Macleod

  • 7 Posts
  • 0 Reply Likes
Hi Rikk,
Thank you very much for the support, much appreciated.
Unfortunately I have tried everything suggested by yourself and everyone else, still the problem persists....... I found some BMP files and cleaned them out, all remaining are JPEG or ORF.
Unsure what else can be done, Adobe have not fed back the status of my trouble tickets and the online chat for technical support is woefully frustrating. The problem has been ongoing since December last year..

Any other help , comments suggestions would be greatly welcomed......

Regards
Photo of Antoine Hlmn

Antoine Hlmn

  • 543 Posts
  • 137 Reply Likes
I did a quick test on iPad and it worked (tested one folder, though) with me.

The only thing I could recommend is to keep in touch with our beloved outsourced helpdesk to put some pressure.
Also, I would recommend to complain in order to get several free months of subscription. I could have a couple of free months, it’s not much, but it’s welcome!
Photo of Cam Mackie

Cam Mackie

  • 6 Posts
  • 0 Reply Likes
I am having the same problem. I have an album with 3029 photos. I click "Store Locally" and it gets stuck at 27 and never progresses.  I have another album of 1533 that is stuck at number 1315, and an album of 3292 that is stuck at 2528?  This is really frustrating, and I really don't want to delete everything and start again hoping for a different result?  Do we know what the problem is, or how to fix it - or do we only have "try this and see if it works" type solutions? I don't have any TIFF files.
Photo of Cam Mackie

Cam Mackie

  • 6 Posts
  • 0 Reply Likes
I cleared the cache and tried to download the album with 3292 photos again, and it got stuck on the same number 2528.  Is there any way for me to tell which image it's having problems with?  Where it's getting stuck?  
Photo of Calum Macleod

Calum Macleod

  • 7 Posts
  • 0 Reply Likes
Hi,
It just happens I have raised another case with Adobe, I had my iPad replaced and ran a fresh install of the app - same problem.
Yesterday I was following up with Adobe online chat who informed me they have identified the problem as XMP file not getting downloaded, I was informed they are working on a fix and will hopefully be rolled out in due course. Hope this info helps in the meantime with this incredibly frustrating problem.

Regards
Photo of Cam Mackie

Cam Mackie

  • 6 Posts
  • 0 Reply Likes
Thanks Calum.  Appreciate the info.  This is very frustrating, but it isn't the first frustrating problem I have with Lightroom.  The "People" functionality is also dodgy.  It keeps asking me "is this the same person" and shows pictures of various things that aren't even people.  It thinks my daughter is "the same person" as everything from stain glass windows to animals to birds to clouds etc!  And even after you click that they're not the same, you get asked the same question over and over when you go into that section.  It doesn't seem to learn?  But this inability to "store locally" without wasting heaps of time could be the final straw. If it's not fixed soon, I think I'll just move to a different system.  (not sure if you've tried any others?)
Photo of Andrew Stencil

Andrew Stencil

  • 1 Post
  • 0 Reply Likes
Hi all, 

Running into the same issues as stated above on multiple counts. 

Device Model: iPad air II
Mobile OS version: 12.3.1
Lightroom version: v 4.3.2 55A26D
Free Space on device: 120gb
Number of images in your all Photos:783
Status of sync (Cloud Icon) Synced and Back up

Only download smart previews is off.

All of my synced photos are from an iPhone 8 raw DNG or an HDR taken with the LR app. On wifi, only smart previews are loading, or the image is processed to it's original format temporarily. After the sync process nothing seems to be being stored locally.

It will load the photo, process the preview, sync the original dng, and show a filled green check on the cloud (signifying a synced photo). But, when I turn off the wifi a sync error occurs, and the status is label as "thumbnail preview not editable".

I attempted the workaround stated above, but no success. I would love some insight into other workaround or ways to make this work. 

The syncing process works completely fine on mobile device (iphone). 

Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5877 Posts
  • 1285 Reply Likes
Lightroom for iOS version 4.4 was just released. Do you still have this issue after installing the update and restarting your device?
Photo of Calum Macleod

Calum Macleod

  • 7 Posts
  • 0 Reply Likes
Thank you for the heads up, I have been waiting patiently for 4.4 as this is when I was advised the problem would be fixed.

However, still the same problem remains, I did a fresh install and still no fix, the store locally hangs as usual.

This is desperate stuff from Adobe! Since January and now will have to wait until the next update if even that is successful.

However thank you for the follow up,

Regards