Starting Photoshop with Japanese IME active (or probably other non-Latin ones) causes shortcut keys to be broken during the session (MacOS 10.9)

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
On Mac OS X 10.9 (Mavericks), it seems that starting Photoshop CS6 while a Japanese IME is active causes the shortcut keys in the menu bar to break. Toolset shortcut keys still work. Broken shortcut keys have their non-modifier keys changed to a crossed out equals sign (≠); see screenshot.



One IME that causes this problem is Kotoeri, the default Mac OS X Japanese IME. Upon switching back to a US input source after booting Photoshop while Kotoeri was active, the shortcut keys are still broken, but the non-modifier keys are now a blank space instead of the crossed out equals sign.

The shortcut key settings file is not modified. Upon closing down and then restarting Photoshop with the US input source active, the shortcut keys work again, and continue to work even after switching back to a Japanese IME with the program active.

This was verified on a 2012 Macbook Air 11", a 2011 Mac Mini, and a custom built Hackintosh computer, all running OSX 10.9. Each machine has the same problem. The Macbook Air also verified that the alternative Google Japanese IME also causes the bug to occur.

All the "common things" such as cleaning out settings files and reinstalling have been attempted and don't solve the problem. Adobe Illustrator and Adobe InDesign don't have this same problem—indeed, literally every single other application I use does not have this problem. The problem only occurs on OSX 10.9, and not before, as also verified by those same three machines I mentioned.

I'd surmise that Photoshop uses an ancient API that had been deprecated for a long time and was finally removed by OSX 10.9. It likely has something to do with character encoding.

Any kind of help on this topic would be very much appreciated. As noted, there is a workaround, but it's kind of absurd that I should be unable to start Photoshop with a Japanese IME.

Final note: an IME is not the same as a keyboard. You can hook up a Japanese keyboard and still use a US input source. Essentially it's hardware independent. My keyboard is Japanese, but it's not relevant here because this is completely abstracted by the OS. The Macbook Air is US, and I've had the same problem with a non-Japanese keyboard.
Photo of dada78641

dada78641

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Hi Dada,

Okay, I tried with in Photoshop CC and CC 2014 with Japanese, Chinese, French, German, Nepali, Hebrew, Greek, Tamil, etc and could not reproduce a problem.  It could be that CS6 might have an issue and I will investigate further, but I cannot seem to reproduce a similar failure in any version of Photoshop that's been released since Mavericks has become available.

Thanks,
David
Photo of Pete Green

Pete Green, Customer Advocate

  • 721 Posts
  • 136 Reply Likes
Also, make sure the OS has installed the latest updates (10.9.4)
Photo of Peter Song

Peter Song

  • 2 Posts
  • 0 Reply Likes
Dada-san,
It's kind of previous Apple issue.
so, would you please confirm your JP OS is the latest one like (10.9.4 for current).
I checked in my machine , it's gone after upgrade.
Thanks,
Peter
Photo of dada78641

dada78641

  • 3 Posts
  • 0 Reply Likes
@Peter,

Thanks. I forgot to mention that I am running on OSX 10.9.4. In other words, even with Kotoeri enabled in that system (and, crucially, set as the active input method), you don't experience the same issue?

On a side note, but there isn't really a "Japanese" version of OSX. You set the locale to Japanese and optionally change the default locale using a Terminal command, but other than that there is no difference. Likewise a Japanese Apple computer can be set to be identical to a US one, without reinstalling anything.

@David,

It's good to know at least this doesn't affect versions post-CS6.
Photo of Peter Song

Peter Song

  • 2 Posts
  • 0 Reply Likes
Dada-san,

There's a tech note with a workaround in Japanese, it might help you out!
http://helpx.adobe.com/jp/photoshop/k...

Thanks,
Peter
Photo of dada78641

dada78641

  • 3 Posts
  • 0 Reply Likes
Hi Peter,

Thanks for looking that up, but this is precisely the workaround I posted in my original message.

I'm still curious as to what causes this. Probably usage of a long deprecated system API.