Spot Removal Tool is Malfunctioning on Lightroom Classic, how to correct?

  • 1
  • Problem
  • Updated 2 weeks ago
  • Not a Problem
Lately when I select spot removal on lightroom classic, the entire image area turns to a flat "traced" version of the image. It makes it much more difficult to use the tool. I have tried updating the program and resetting settings but it doesn't fix it. Any ideas?
 
Photo of Sara McIngvale

Sara McIngvale

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 weeks ago

  • 1
Photo of Andrew Rodney

Andrew Rodney

  • 1044 Posts
  • 231 Reply Likes
Looks like the sharpening mask over lay. 
Anyway, first thing to try is turning OFF the GPU options in preferences. Do you still see this? 
Photo of Sara McIngvale

Sara McIngvale

  • 4 Posts
  • 0 Reply Likes
unfortunately no, it did not fix it
Photo of Sara McIngvale

Sara McIngvale

  • 4 Posts
  • 0 Reply Likes
Okay, I actually figured it out. When the spot removal tool is selected, there is a toolbar at the bottom that has a checkbox for "Visualize Spots". It was checked off which gave it that overlay. I must have somehow selected that or it was a default in the update. Thanks for your help!
Photo of Jerry Syder

Jerry Syder

  • 499 Posts
  • 227 Reply Likes
You beat me to it.. see reply below.. you must have hit A(shortcut) by accident.
Photo of Jerry Syder

Jerry Syder

  • 499 Posts
  • 227 Reply Likes
Try pressing A when you're in the spot removal tool. Or deselect 'Visualize Spots' at the bottom, left. You may also want to experiment with the slider to the right of Visualize spots as it give different gradients of that function. Or simply turn it off if you don't like it.
Photo of Sara McIngvale

Sara McIngvale

  • 4 Posts
  • 0 Reply Likes
That did it! My cat likes to walk over my keyboard when I work so I bet he hit the shortcut. Thanks for your help!
Photo of Jerry Syder

Jerry Syder

  • 499 Posts
  • 227 Reply Likes
When it happens, I blame the cat too hahaha. You're welcome
Photo of Steve Gandy

Steve Gandy

  • 190 Posts
  • 59 Reply Likes
It is a feature not a bug as they say. Use the slider, actual dust spots will show as a donut shape.