Lightroom for web: Sorting photos in shared album

  • 3
  • Problem
  • Updated 2 months ago
  • Acknowledged
  • (Edited)
It's driving me mad...

I open Lightroom web, go on my album, go in the Display tab, choose "sort by Date taken", then "invert order", so the photos are displayed like I want them to, the most recent ones at first. 

Then I got on the shared album link, and they are absolutely not displayed by most recent...
Why?!
Photo of Charlotte Razon

Charlotte Razon

  • 25 Posts
  • 1 Reply Like
  • confused

Posted 2 months ago

  • 3
Photo of Jim Wilde

Jim Wilde, Champion

  • 356 Posts
  • 135 Reply Likes
It's working as expected for me. Are you clicking on "Reverse Order" on the Display tab, or the Photos tab (it has to be on the Display Tab to be seen that way using the shared album link)? And have you refreshed the browser window for the shared album link?
Photo of Charlotte Razon

Charlotte Razon

  • 25 Posts
  • 1 Reply Like
I used « reverse order » on the display tab and refreshed the browser window for the shared album link, like you said.
It didn’t work for like ten times (and instead displayed photos in a very weird anarchical display), until I disconnected My account from everywhere, reconnected and did the change again...
I hope I won’t have to do this every time I need to sort a shared album view...
Photo of Luke Rymarz

Luke Rymarz, Official Rep

  • 2 Posts
  • 1 Reply Like
When you reverse order there is a save that happens in the background.  If you have large amount of photos it's possible to click over to the shared album link before the save has completed and the order will be wrong.  A refresh of the share in that case _should_ show you what you expect.
Photo of Charlotte Razon

Charlotte Razon

  • 25 Posts
  • 1 Reply Like
Well... I tried again... for the same result, everything is mixed up. Do I have to wait more than 1 minute before refreshing the link?
Photo of Luke Rymarz

Luke Rymarz, Official Rep

  • 2 Posts
  • 1 Reply Like
Actually it looks to me like you've found a bug.  The cause appears to be using that sort control twice quickly.  Two separate changes are being applied at once when you do that and it's resulting in a jumbled mess.  I'll file an issue internally and hopefully we can get a fix soon.

In the meantime, it looks like the ugly workaround is to "sort by Date taken", confirm that your share has that order, and only after it looks correct select "invert order".
Photo of evikne

evikne

  • 42 Posts
  • 6 Reply Likes
I've experienced the same thing.

It is also frustrating that if we add more photos after we've sorted, the new photos always appear below all the others and do not follow the sorting order. Every time new pictures are added, we have to repeat the sorting.
Photo of Charlotte Razon

Charlotte Razon

  • 25 Posts
  • 1 Reply Like
@luke Oh, I’m glad you could figure out the steps to reproduce the bug! I’ll do the workaround in the meantime thanks :)
@evikne Oh yeah? I think I don’t have that, but I’ll check one more time.