All desktop programs show Photoshop icon

  • 1
  • Question
  • Updated 4 years ago
  • (Edited)
HOW CAN I REMOVE THE PHOTOSHOP TAKING OVER MY OTHER PROGRAMS ON MY DESKTOP? ALL PROGRAMS ON MY DESK TOP HAS A PS LOGO AND WHEN A ONE OF THIS PROGAMS IS INITIATED THE PHOTOSHOP COMES ON INSTEAD THE PROGRAM
Photo of ANTONY RODRIGUEZ

ANTONY RODRIGUEZ

  • 1 Post
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Photoshop doesn't do that.

It sounds like you might have a problem with your system, or malware on your system (not directly Photoshop related).
Photo of David

David, Official Rep

  • 2721 Posts
  • 373 Reply Likes
Howdy Anthony,

You're running some flavor of Windows, such as WinXP or Win7, right? What you're seeing is the result of file association being linked to Photoshop. If you look at the extension of the files involved, you'll notice that they're .PSD or .GIF or .JPG or .TIF, etc. If you do not want Photoshop to automatically open these files, then all you need to do is change the file association parameters. To do this:

1) right click on one of the file in question
2) from the context menu, click Open With > Other Program
3) select the application you'd like to use
4) click the check box "Always use the selected program to open files of this kind"
5) before you click Ok, I would *STRONGLY* suggest you check the file name and type (second line at the top) and NOT CHANGE any file that's .PSD or .PDD.

This should solve this problem, but keep in mind, it will also mean that Photoshop will NOT open when you double-click files of this type. You will need to launch PS and then click File > Open and select the file in the future.

Thanks,
David
Photo of Sarfraz Khan

Sarfraz Khan

  • 1 Post
  • 0 Reply Likes
Your .ICO files are setup to be opened with Photoshop. Reassociate ICO with Windows Photo Viewer and recreate the IconCache.db.

Instructions:
1. Right click an ICO file on your computer.
2. Hover over "Open With" and click "Choose Default Program".
3. Choose "Windows Photo Viewer", keep the "Always use" checkbox checked and click close.
4. Go to %LocalAppData% in your Windows Explorer (basically go to My Documents and in the address bar on top type "%LocalAppData%".
5. Delete the file IconCache.db. If you can't see the file, it's hidden. Make sure you can view your hidden files.
6. Now either restart explorer.exe or restart the computer, which ever feels easier for you to do.

Note for #1) If you don't have an ICO file, open notepad and save the file as something.ico with Save As Type: All Files (*.*)