Photoshop CC 2015: Smart Filters turned off on Smart Layer when file re-opened

  • 3
  • Problem
  • Updated 4 years ago
  • (Edited)
I'm working on an RGB PSD document which contains an embedded Smart Layer (RGB jpeg). I have set Smart Filters on the layer for Hue/Saturation and Invert.

Sometimes when I open it, the Smart Filter layer is set to off.
Very annoying. And strange.

I click to display the Smart Filters and continue working on the file.
I can close and open the file and the filter is still on. But the next day I open the file, and the Smart Filter is off again. Of course, sometimes the switch happens on the same day, but I'm yet to figure out what is triggering it.

Anyone else come across this behaviour?
I'll work to reproduce.


(Photoshop CC 2015, PC, Win 7 64bit)
Photo of Anthony Edge

Anthony Edge

  • 108 Posts
  • 23 Reply Likes

Posted 5 years ago

  • 3
Photo of Kevin Stohlmeyer

Kevin Stohlmeyer

  • 4 Posts
  • 0 Reply Likes
Just experienced a similar situation. Smart filters appear to be active but not showing results on the image until you hide/show again. 
Photo of Pete Green

Pete Green, Customer Advocate

  • 780 Posts
  • 165 Reply Likes
Strange - I wonder if resetting Photoshop's preferences would make any difference?
Photo of Kevin Stohlmeyer

Kevin Stohlmeyer

  • 4 Posts
  • 0 Reply Likes
Gone through all the normal fixes. It appears that changing the color space in the doc requires you to turn the filters on and off to reset the visibility. I'll be filing a bug report.
Photo of Cristen Gillespie

Cristen Gillespie

  • 2016 Posts
  • 700 Reply Likes
I've tried to reproduce it, and so far, I can't. I've changed color space. I've changed color mode. I've added an adjustment as a smart filter. I've quit and relaunched PS in between closing and opening the file. I'll keep trying to see if this file does it, but it's something I've never seen.  Several 3rd party filters won't rerun and return any results, but that's completely obvious and show/hide doesn't help at all, unlike this. On a Mac running Yosemite.