Smart Collection multiple windows

  • 1
  • Problem
  • Updated 1 year ago

The same problem as always: Lightroom's poor performance.

After several minutes of creating and editing Smart Collections Lightroom becomes very slow, simply clicking on one of them and waiting for the results takes 8-10 seconds.

I despair and double-click on a Smart Collection to edit it, but it doesn't respond.  I double-click again several times and it does nothing.  Finally presents me the editing window, but duplicated many times!

The only solution: close and open Lightroom. (And I was laughing at Microsoft applications)

Imac 27", 24 GB RAM


There seems to be only one window, but there are several perfectly aligned, so I spread them to show the mess:

Photo of drobtitan

drobtitan

  • 29 Posts
  • 7 Reply Likes

Posted 1 year ago

  • 1
Photo of drobtitan

drobtitan

  • 29 Posts
  • 7 Reply Likes
Posting here is like talking to the hand, and it's supposed to be a site for feedback.

At least, somebody change the status of this post to "Acknowledged" (like that's going to do any good)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4271 Posts
  • 814 Reply Likes
We can only mark the post as acknowledged if we can reproduce the issue. So far, I am unable to reproduce what you are seeing. 

Sometimes weird behavior is corrected/cured by resetting the preferences. 

Reset Procedure: 

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom. 
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.

Does the behavior continue after resetting the preferences?
Photo of drobtitan

drobtitan

  • 29 Posts
  • 7 Reply Likes
In fact, I did something better: I installed High Sierra and Lightroom from scratch on an external SDD, and I keep the pictures and the lrcat on the iMac's internal disk.  Of course, this combination runs faster.

What I'm doing is classifying 4000+ small JPG files with 100+ keywords, several with sub keywords like this:

gender
      male
      female

location
      stairs
      wall
      floor
      fountain
      tree
      ....

I filter and create Smart Collections like these:

toddler, !gender

couple, sitting, floor

ring, !wedding

I assign keywords and save metadata changes to the JPG files all the time.

I type quickly, Lightroom is stunned, I don't know why because at the start of the job works well.  It degrades over time.

No cropping, no radial filter, no presets, no printing, nothing but keywords, smart collections and filters.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1111 Posts
  • 359 Reply Likes
Try setting the Metadata panel to 'Minimal' display data.  If that doesn't help try resetting LR Preferences as suggested by Rikk Flohr. I would suggest copying the current Preferences file to your desktop so you can quickly restore it if the issue persists. https://helpx.adobe.com/lightroom/kb/preference-file-and-other-file-locations---lightroom-6.html