Photoshop: Slow tool and drawing response on MacOS 10.10 Yosemite while rulers are enabled

  • 4
  • Problem
  • Updated 3 years ago
  • Acknowledged
  • (Edited)
Since upgrading to Mac OS X Yosemite (see: 10.10.1), Photoshop hasn't been playing nice. All tools that require "drawing" (that is, click-and-drag motions) experience a small amount of lag. It appears that the system is taking a moment to realize that the mouse has clicked, but after that, no lag is observable while actually dragging. This affects tools like the Brush tool, Lasso tool, Marquee tool, Zoom tool, so on and so forth. It's notable that I've not been able to reproduce this with the Polygonal Lasso tool, which is not a drag-motion tool.

This issue CAN BE REPRODUCED ONLY USING THE MOUSE, but the effects are more subtle. Perhaps people using the mouse haven't even noticed. The issue is significantly more troublesome on tablets, however. Using the brush tool with a pressure sensitive tablet pen is a huge headache, if not utterly impossible. On a tablet, the issue is so bad that, often while doing small, quick motions, the program will fail to even register the stroke. Lines simply won't get drawn, for example.

This leads me to believe that 1) it's not an issue with the tablet software, and 2) it is somehow related to pressure sensitivity. Maybe. Again, ALL click-and-drag tools, even those that don't even have a pressure-sensitive option, are affected.

I briefly troubleshooted basics with a support technician who was unable to correct it and, in the end, broke the program completely (opening and closing preferences caused the program to crash, even without changing anything). I was forced to reinstall the whole program from scratch. Despite the headache (and the embarrassment of having a support technician break the program), it did give me an opportunity to test a fresh install. This did not fix anything.

This issue does go away entirely, both WITH AND WITHOUT a tablet, simply by disabling rulers. Don't misread what I'm saying - this is NOT a work-around - not having rulers is not an acceptable workflow for some of us. If I didn't think it were helpful information to expedite the process of FIXING this issue, I almost wouldn't have pointed it out for fear of someone dismissing this issue due to it "having a solution."

I have three versions of Photoshop currently installed: CS6, CC and the CC2014 update. All three of these programs experience this same bug.
Photo of Ian Karlovsky

Ian Karlovsky

  • 3 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 4
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Official Response
We have been able to reproduce this, and are investigating the cause.