Photoshop CC 2017: Slow cloning stamp and healing brush

  • 6
  • Problem
  • Updated 8 months ago
  • (Edited)
since the CC2017 update, the cloning stamp and healing brush became slow.
sometimes the source symbol stays even after the Alt is released, need to press Alt again to get to the target brush.

still have the cc2015.5 and the problem is only in new 2017 version.

anyone else with the same problem?

thanks!
Photo of laden m

laden m

  • 168 Posts
  • 17 Reply Likes

Posted 2 years ago

  • 6
Photo of Creative Catalyst

Creative Catalyst

  • 88 Posts
  • 18 Reply Likes
Yes! Me too. Not only that, if you have the overlay on, it will lag behind for several seconds at times. Also, it appears that it's cumulative. It gets worse the longer Photoshop is open.

I have adjusted my Performance options in Preferences. I am using my GPU to the fullest. I have cleared my cache and I have set up 2 SSD scratch discs. This hasn't ever been an issue before CC 2107.

It might help to post your machine build.

I am running Windows 10
16GB DDR3 RAM
500GB SSD
Intel Core i7 Broadwell
Nvidia GTX 980 GPU
Photoshop CC 2017
Photo of Creative Catalyst

Creative Catalyst

  • 88 Posts
  • 18 Reply Likes
Also, the Hand Tool lags similarly. If I press the space bar, click, hold for a few seconds, it will move the document. If I do it too fast, click and drag does nothing.
Photo of laden m

laden m

  • 168 Posts
  • 17 Reply Likes
for me, the hand tool became slow after CC was introduced and after that it was never responsive as i expect it to be.
Photo of laden m

laden m

  • 168 Posts
  • 17 Reply Likes
yea, sure!
i always forget this:

here my machine:

Mac Pro (late 2013)
3.5 GHz 6xCore Xeon E5
64GB RAM
500GB SSD
Dual AMD FirePro D500 GPUs
Photo of laden m

laden m

  • 168 Posts
  • 17 Reply Likes
i have also serious brush issues. when using the brush with Shift+Click to draw a connected line, sometimes the points doesn't connect. 
So for me this is general Brush, Stamp, HealingBrush BUG.

thinking about going back to CC2015.5, there is anyway nothing new in the  CC2017, except the super slow new NEW Image pop-up. (it was turned off in the Preferences right after first test)
Photo of Scifisteve55 Baruday

Scifisteve55 Baruday

  • 1 Post
  • 0 Reply Likes
Turn flow rate to 100%. Suddenly it will be much faster!!! That's for any version of photoshop.
Photo of snark

snark

  • 3 Posts
  • 0 Reply Likes
Thanks for the response. But my flow rate is already 100%
Photo of snark

snark

  • 3 Posts
  • 0 Reply Likes
I thought it was me, but I've been having this problem for months now. I'm on the latest builds of everything. I am doing a LOT of clone stamping and healing and this has already caused me to make mistakes.  There is a serious lag between pressing the ALT key and having the "pickup" target cursor show. If I don't notice it and release alt I am using the previous pickup target. Very bad and not always noticeable when you are doing 2 a second.  (The behavior of File>New (Ctrl-N) has a similar annoying habit now but that's a different post). I think someone "clever" has implemented a multi-threaded state machine internally without accounting for latency. 

Alienware 17 R2
Intel Core i7-4720HQ @ 2.60GHz 2.6GHz
Windows 10 64-bit
16G RAM
512G SSD
Photo of laden m

laden m

  • 168 Posts
  • 17 Reply Likes
in my case most of the problems you are mentioning was actually caused by the wacom tablet driver.
maybe it is worth trying updating or downgrading the driver of your tablet. if you have one. in my case downgrading of the tablet driver solved most of the many cursor problems i had, including the ones you are mentioning.


good luck!
Photo of snark

snark

  • 3 Posts
  • 0 Reply Likes
Thanks, I use a pretty vanilla (Logitech/wireless) mouse and a lot of wrist. Same 'ol wrist.  I don't detect any lag except in PShop. I'll try using another mouse.  

UPDATE: I switched to a USB mouse and see the same symptoms... Most times a .5 sec. delay between pressing ALT and seeing the cross-hair. Same for the release of ALT.  

BUT WAIT, THERE'S MORE... (more diagnostics)  I don't see the delay when I use the Ctrl key, which is pretty much instantaneous.

Maybe there is a Windows function getting in the way? Any thoughts? I've checked the accessibility and keyboard settings which are all defaults. I see discussions online but they all relate to pen/touch (as Iaden's did).