Photoshop: Single row of pixels are become lost on text and Vector Smart Objects in CS5, Mac OSX 10.6.7

  • 3
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
I have attached a close-up image of the problem. As you can see there are a few layers of type, and some graphics behind it. The font I used is very common (Cooper Black) and the blue letter "r" in the middle of the screen is missing a row of pixels. Notice that the "r" behind it is the same font, but perfectly fine.

Obviously type in Photoshop shouldn't be doing this. I have noticed it with a number of fonts in Photoshop, but I've even seen it happen when I place smart objects from Illustrator. If I move the problem layer, sometimes it goes away, but more often it doesn't. Sometimes other portions of the layer will lose a row of pixels instead.

Now this problem may seem minor, since it is only one row pixels, but if you apply a layer style, such as a bevel, it acts as if those pixels are supposed to be that way. Therefore you have a bevel wrapping around that one row of missing pixels.

I have tried creating PDFs out of these files, and the problem still exists after the export. This makes printing a huge pain, because I have to go in with a brush and fix the problem layers before I print. This is something I have never had to do in past versions of Photoshop.

Photo of Jonathan Cilley

Jonathan Cilley

  • 8 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 3
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Official Response
Fixed in Photoshop CS6 or later.