Lightroom Classic: Since the latest update-unable to apply settings to multiple images simultaneously

  • 1
  • Question
  • Updated 2 months ago
  • Answered
  • (Edited)
attempting to copy settings to multiple selected images-the settings are only applied to the first picture in the group and then lightroom stops updating any of the additional pictures
Photo of Al Edlund

Al Edlund

  • 5 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16663 Posts
  • 2726 Reply Likes
Which product/version are you using?
Photo of Al Edlund

Al Edlund

  • 5 Posts
  • 0 Reply Likes
perating system: Windows 10 - Business Edition

Version: 10.0.19551

Application architecture: x64

System architecture: x64

Logical processor count: 12

Processor speed: 3.1 GHz

Built-in memory: 32573.1 MB

Real memory available to Lightroom: 32573.1 MB

Real memory used by Lightroom: 1954.9 MB (6.0%)

Virtual memory used by Lightroom: 6212.4 MB

GDI objects count: 714

USER objects count: 1953

Process handles count: 2110

Memory cache size: 114.2MB

Internal Camera Raw version: 12.1 [ 351 ]

Maximum thread count used by Camera Raw: 5

Camera Raw SIMD optimization: SSE2,AVX,AVX2

Camera Raw virtual memory: 911MB / 16286MB (5%)

Camera Raw real memory: 932MB / 32573MB (2%)

System DPI setting: 144 DPI (high DPI mode)

Desktop composition enabled: Yes

Displays: 1) 3840x2160, 2) 2560x1440

Input types: Multitouch: Yes, Integrated touch: Yes, Integrated pen: No, External touch: No, External pen: No, Keyboard: No



Graphics Processor Info: 

DirectX: NVIDIA GeForce RTX 2080 (26.21.14.4166)





Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic

Library Path: C:\2020_rt_florida\images\Lightroom\tl_02_24\tl_02_24.lrcat

Settings Folder: C:\Users\edlun\AppData\Roaming\Adobe\Lightroom



Installed Plugins: 

1) AdobeStock

2) Facebook

3) Flickr

4) Nikon Tether Plugin



Config.lua flags: None



Photo of Robert Somrak

Robert Somrak, Champion

  • 558 Posts
  • 187 Reply Likes
In develop if you use the Copy/Paste commands the Paste will only apply to the most selected photo unless you turn on AutoSync
Use the Sync button instead so you don't have to turn on Autosync.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4969 Posts
  • 1384 Reply Likes
This misbehavior also occurs in Library with just one photo showing (Loupe view). It's "by design".

In addition to Sync or Auto Sync, you can right-click one of the selected thumbnails in the filmstrip and do Develop Settings > Paste Settings.  

Why right-clicking the thumbnails pastes to all photos while the menu command Settings > Paste Settings, and its keyboard shortcut, pastes to only the most selected photo, is a mystery. In general, LR is highly inconsistent about which photos are affected by which commands when only one photo is showing in Loupe view:

https://feedback.photoshop.com/photoshop_family/topics/long-time-pet-peeves?topic-reply-list[setting...
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5527 Posts
  • 2204 Reply Likes
> Why right-clicking the thumbnails pastes to all photos while the menu command Settings > Paste Settings, and its keyboard shortcut, pastes to only the most selected photo, is a mystery.

The logic was that if you're right-clicking on the thumbnails, Lightroom knows that you know there's multiple photos selected, so it makes an exception to the "only what's shown in the main preview area" rule.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4969 Posts
  • 1384 Reply Likes
That's the usual explanation, but consider:

Right-click Reset and Proof only operate on the most-selected filmstrip image, not all selected images. Why the exception to the exception?

If you click on the flag or target-collection badge of a filmstrip thumbnail, only that image is flagged or added to the collection, not the entire selection, even though LR surely "knows" that you know multiple images are selected in that case (as it does when you right-click Set Flag or Add To Collection).

File > Export in Develop Loupe will export all the selected photos, even though LR doesn't "know" that you know multiple images are selected. Similarly, Photo > Photo Merge operates on the entire selection. But Photo > Create Virtual Copy only operates on the most-selected image.

In general, the rules for which filmstrip photos are affected by which commands in Loupe are so inconsistent that no mere mortal could possibly keep them in their head:
https://feedback.photoshop.com/photoshop_family/topics/long-time-pet-peeves?topic-reply-list[setting...

Extra credit: In Develop Loupe, suppose photos A, B, and C selected and you right-click an unselected thumbnail and do Paste Settings. Which photos are affected?  If you right-click Auto Settings, which photos are affected?  No cheating by actually trying it in LR.
Photo of Robert Somrak

Robert Somrak, Champion

  • 558 Posts
  • 187 Reply Likes
I didn't try the extra credit John because I didn't know the answer : ).   It would be better if ALL things in Develop only worked on a single image without AutoSync so it would be more consistent.  I am a big fan of program command consistency which Lr is unfortunately lacking in iseveral areas but for the most part have learned to work around then and in the Right Click Paste scenario have learned to use for my benefit.
(Edited)
Photo of John R. Ellis

John R. Ellis, Champion

  • 4969 Posts
  • 1384 Reply Likes
For the extra-credit answer, see the other post I linked to.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5527 Posts
  • 2204 Reply Likes
> Right-click Reset and Proof only operate on the most-selected filmstrip image, not all selected images. Why the exception to the exception?

Yeah, I agree things have diverged over time, so who knows what's a bug these days!
Photo of eartho

eartho, Champion

  • 1329 Posts
  • 436 Reply Likes
How are you trying to paste to multiple? Please be specific.
Photo of Al Edlund

Al Edlund

  • 5 Posts
  • 0 Reply Likes
The video does not test the scenario we are currently  discussing (with the original image being cropped). Happy to create another video if needed for Adobe to work on the known anomalies you guys have documented. I'm just trying to get a string of time-lapse photos put together for a vacation project. I do appreciate your help on getting this done.
Al Edlund
Photo of Robert Somrak

Robert Somrak, Champion

  • 558 Posts
  • 187 Reply Likes
Maybe its a Windows only bug as Crop pastes fine for me in macOS 10.14.6
Photo of eartho

eartho, Champion

  • 1329 Posts
  • 436 Reply Likes
Al, syncing the crop works fine for me here and always has.
Photo of eartho

eartho, Champion

  • 1329 Posts
  • 436 Reply Likes
The workflow - in Develop, select the photo which has the settings you want to copy, then shift select the sequence in the thumbnails, then hit the sync button and Select All settings, sync.
Photo of Philippe Coudé du Foresto

Philippe Coudé du Foresto

  • 93 Posts
  • 33 Reply Likes
Pasting crop works fine on my Windows 10.