Lightroom Classic: Side panels erratically overlay import dialog (latest macos)

  • 39
  • Problem
  • Updated 9 months ago
  • Solved
  • (Edited)
Screen recording of bug attached
I _can change side panels width but cant hide them while import dialog is under

Lightroom Classic version: 8.0 [ 1193777 ]

License: Creative Cloud
Language setting: en-RU
Operating system: Mac OS 10
Version: 10.14.1 [18B75]
Application architecture: x64
Logical processor count: 8
Processor speed: 2,7 GHz
Built-in memory: 16 384,0 MB
Real memory available to Lightroom: 16 384,0 MB
Real memory used by Lightroom: 2 927,5 MB (17,8%)
Virtual memory used by Lightroom: 8 782,1 MB
Memory cache size: 967,0MB
Internal Camera Raw revision: 61
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 2366MB / 8191MB (28%)
Camera Raw real memory: 2382MB / 16384MB (14%)
Displays: 1) 5120x2880

Graphics Processor Info: 
Metal: AMD Radeon Pro 455

Application folder: /Applications/Adobe Lightroom Classic CC
Library Path: /Users/medvdv/Pictures/Catalog 2018/Catalog 2018.lrcat
Settings Folder: /Users/medvdv/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Canon Tether Plugin
4) Facebook
5) Flickr
6) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: LG UltraFine Display Audio
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: 12.1x4
CoreImage: true
GL_RENDERER: AMD Radeon Pro 455 OpenGL Engine
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-2.2.8
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 
Photo of alexander medvedev

alexander medvedev

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 39
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7714 Posts
  • 1778 Reply Likes
The status on this bug (see top of page) is Acknowledged. When the bug is fixed, we will change to status to "Solved".  Normally we also post an update to the message thread when it is fixed.

This issue is still open in our system. 
Photo of Antoine Hlmn

Antoine Hlmn

  • 919 Posts
  • 222 Reply Likes
Rikk, you can understand people’s frustration about Adobe not delivering what’s been promised with the change to the subscription model instead of perpetual licence: an always up to date software. Nine months and four versions of LR without a fix doesn’t seem to fulfill te contract.

I don’t really mind because there’s a workaround, but it feels like LR classic is not a priority at all. I wish I were wrong.
Photo of Grégory Millasseau

Grégory Millasseau

  • 10 Posts
  • 1 Reply Like
« This issue is still open in our system. »
That’s precisely the problem: FIX IT!
Photo of Paul Atkinson

Paul Atkinson

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom Classic 8.4 bug: import folders hidden by Library side panels when view....


I have encountered a problem when attempting to import photos when working in Lightroom Classic's Library module (with the window displayed full screen), with both left and right side panels displayed (not self-hiding).   When I attempt to import photos, the Import screen appears, but the standard Library side panels are covering where you select the folder, as well as the button to import, such that all I can click on is a tiny sliver of the "Cancel" button that is sticking out from under the right panel.  If I click on the arrows to hide the Library side panels BEFORE clicking "Import", then I can import as usual.  However, if I have clicked "Import" first, I can't even do that because the arrows to hide the side panels disappear.

I have contacted Adobe Support, and the fix was to disable my graphics processor, restart, and then re-enable  it, which allowed everything to work normally exactly once, just long enough for me to think Support had fixed the issue.  (And which I was able to duplicate myself, working normally exactly once, by performing the exact same steps later.)

I am currently running Lightroom Classic 8.4 on an iMac that is just a couple months old, on Mojave 10.14.5, with a Radeon Pro 580X 8 GB graphics processor.  I had the same problem with the previous Lightroom, and unfortunately it was not fixed in the just-released update.

Here is a screenshot after clicking "Import", where you can faintly see the import folders behind the left side panel, and maybe even make out the sliver of the "Cancel" button on the right.

Photo of David


  • 7 Posts
  • 3 Reply Likes
This reply was created from a merged topic originally titled Lightroom Classic 8.4: Import hangs sometimes (macOS).

I upgraded to LR classic 8.4 last week. I have a macBook Pro running Mojave that is up to date. All is well except for Import. three times now (of approx 12 times) after I click on "import" the window one usually sees to permit selection of source etc is hidden behind the regular view of the Library window, and so no selection or "cancel" is possible. The only work around i found is to command-Q to quit Lr and then to Force Quit LR in sequence... then its fine for a while.
Photo of John R. Ellis

John R. Ellis, Champion

  • 5169 Posts
  • 1476 Reply Likes
A more reliable workaround is to drop out of full-screen mode before going to the Import window.
Photo of Byron Chin

Byron Chin

  • 15 Posts
  • 6 Reply Likes
Another workaround (simpler in my opinion) is to hide the offending panes by pressing Shift + Tab.

Even though the problem is easy to work around, I find it quite unacceptable that this problem has been around for months, and through numerous updates, and still has not been fixed.
Photo of Antoine Hlmn

Antoine Hlmn

  • 919 Posts
  • 222 Reply Likes
You don't understand, Byron. That's why a subscription based licence is better than a perpetual license. So pay monthly but you'll have a forever up to date software. Amazing!

... they said...
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7714 Posts
  • 1778 Reply Likes
Official Response
Lightroom Classic 9.0 was released earlier today and contained a fix for this issue. Please give it a try and confirm it is working for you after updating. Thanks for your patience.