Photoshop: Misunderstood setting layer opacity via keyboard's numpad

  • 1
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
When using the keyboard numpad to set layer opacity percentage and typing 100 (without focusing in the opacity input), the layer opacity changes to 0. All other values set properly. This is an issue on both Mac and PC for Photoshop 14.2.1
Photo of Nikolay Belitchenov

Nikolay Belitchenov

  • 3 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
That is not a bug, but you misunderstood the shortcuts for setting opacity.
Typing 0 by itself sets the value to 100.
Typing 00 sets the value to 0.
Photo of Nikolay Belitchenov

Nikolay Belitchenov

  • 3 Posts
  • 0 Reply Likes
Thanks for the answer and clarification.
I wonder when that changed - older versions always accepted 100 as 100, rather than 100 -> 00 -> 0. Example CS 5.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
No, older versions only supported 0 setting the opacity to 100, and had no way to set the opacity to zero. So the 00 shortcut was added to set the opacity to zero.

You were typing too many characters, when only the last one mattered: setting the opacity to 10, then to 100 on the last zero.
Photo of Nikolay Belitchenov

Nikolay Belitchenov

  • 3 Posts
  • 0 Reply Likes
Thanks for clarifying. Just a suggestion: if 1:99 = 1:99, should 0=0 and 100-100?