Lightroom 4.1 RC2: Memory Leak?

  • 5
  • Problem
  • Updated 7 years ago
  • (Edited)
Lightroom4.1 RC2 grows from approx. 250,000K to in approx. 2G while working on in the Library module ONLY. No image modification at all. This occurred in only 1.5 hours of work. It settles back to approx. 1.1G of memory after stopping all activity in LR.

In my opinion, this is way out of control.
Photo of HHHeflin

HHHeflin

  • 15 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 5
Photo of jdv

jdv, Champion

  • 728 Posts
  • 56 Reply Likes
Memory growth is non-deterministic, as it depends on what other processes need these resources, and various performance guarantees that the app makes when providing user feedback and so on.

What you describe is pretty normal. Lr will allocate memory as it needs to in order to fit all the stuff you've asked for. As stuff is nulled out it is available for collection, which will happen when it happens, usually when the app is in a quieter state for some amount of time.

There is always going to be a space/performance trade-off. We keep things in memory so that we can get to them quicker. So, Lr will never release all of those resources, just what is marked for release. If the OS is under pressure to supply other processes with resources, it will make the best choice it can among those competing apps, with the inevitable worst-case result being virtual memory thrashing.

But a real memory leak will not release any of that memory, or gain it slowly. If you are seeing it stable around 1Gb over days or weeks of use, this is pretty normal.
Photo of Sean Phillips

Sean Phillips

  • 159 Posts
  • 47 Reply Likes
I have the same problem, only worse. Memory use grows to 6+ GB out of 8 and RC2 never releases it. The program gets so sluggish that I can't even do basic edits or move around files. Have to restart every 15 minutes or so. I'm reverting back to RC1.
Photo of HHHeflin

HHHeflin

  • 15 Posts
  • 0 Reply Likes
LR4.1 resting/startup memory is between approx 186,000K and 260,000K. However, after working and having the upped it to 2G it still did not drop to below 1G after more than 1 Hour of inactivity. That's a lot of RAM to hold onto even while it's simply idling without any activity.
Photo of Simon

Simon

  • 8 Posts
  • 0 Reply Likes
W7 64 4GB RAM

I don't know if it's related but

when LR4.1RC2 becomes sluggish,
if you exit LR and check what's happening with
W7 Resource Monitor (C:\Windows\System32\resmon.exe),
it takes minutes to get rid of Lightroom.exe references.
Photo of Dan Berdal

Dan Berdal

  • 34 Posts
  • 2 Reply Likes
See the attached screen shots. I was trying to find why i was missing over 6gb of available ram....

Lightroom is reporting that it is using 1.9GB of ram, which seems reasonable. But as soon as I close lightroom it releases 7GB or ram!!



Photo of Sean Phillips

Sean Phillips

  • 159 Posts
  • 47 Reply Likes
That's just awesome.
Photo of kenny szu

kenny szu

  • 1 Post
  • 0 Reply Likes
I have windows 7/64 bit/24 GB of ram/I7 2.6Ghz. LR4.1RC2 is doing some very weird stuff that's not just lead me to think there is some sort of memory leaking, plus more.

I have memory issues like most of you guys have. Under my observation, LR4.1RC2 sometime can eat up to 14GB of ram. Even thought TASK MANAGER only reporting 2.1GB used?? I know that can be very subjective when it comes to memory usage on a system, it depends on your memory page in/out..etc. I was only tweaking CR2 files, they are from various different Canon cameras. I wasn't editing TIFF, no external editors were use for whole "test session".

On background idle LR4.1RC2, it is also taking up 4 cores out of 8 cores on the process doing "SOMETHING" being idle for at least 2-3+ hours. I stare at the Task manager for awhile, memory it uses will cycle through from 650 MB ~ 2.1GB. Then eventually it drop to 650MB and cycles. Of course, my memory usage system wise just keep going up.

As far as disk spaces, if I leave 20GB in where LR4.1 RC2 is install, it takes 6GB away just for idling. Mind you that the cache is configured in a separate directory, I have went through preferences to confirm that multiple times. It was also configured for 2GB. I don't recall LR2/3 was doing such thing? Space will clear up once I shutdown LR4.1 RC2.

Just to clear it up:

LR installed in C:\ (2GB)
Photo and Video Cache configured to point at O:\ (3GB)

I'm not sure if any strange behaviors I mentioned above is "normal" since I just started to use LR4.1 RC2 for a week. I hope all the issues will be address for final LR4.1