Lightroom Classic: Serious memory leak

  • 8
  • Problem
  • Updated 3 days ago
  • (Edited)
For a long time I am troubled by a huge memory consumption of my system. Today I digged more deeply into what is going on with all the memory being used by no processes. Windows 10 Task Manager was showing more than 21GB of RAM used. However, there were only three memory hungry processes listed in the Processes tab: Adobe Lightroom Classic CC eating up 3.5GB, Firefox 2.5GB and Adobe Bridge with roughly 1GB. All the processes listed could add up to no more than 8GB of memory.

In my next step I tried to follow this article:

RAMMap was showing 17.7GB in Active Process Private memory. It was clear from the Processes tab that all the remaining memory was allocated by the "MemCompression" process. I then decided to exit Lightroom Classic CC to see what hapens. Whooping 12GBs were released instead of the 3.5GB shown in Task Manager. When starting Lightroom again, 3.5GB is shown in Task Manager as before and the same amount shows in RAMMap under Lightroom's private memory.

I am using Lightroom Classic CC on my developer notebook with 32GB of RAM and do not currently have another machine with less physical memory available to test the behavior. In the time of discovering the issue I was working in the Development module with a set of 2 500 photos filtered to a view of only 224 images.
Photo of Lukáš Chmela

Lukáš Chmela

  • 10 Posts
  • 2 Reply Likes

Posted 11 months ago

  • 8
Photo of Jeff


  • 63 Posts
  • 19 Reply Likes
If you want to try this with less memory, you can limit the amount using the system configuration utility. Run sysconfig, select the Boot tab, then click advanced options. You can change the number of procs and the maximum memory. Then reboot. Make sure to set it back of course.
Photo of Katrin Serova

Katrin Serova

  • 6 Posts
  • 5 Reply Likes
Lightroom had this memory issue for as long as I can remember on the Mac platform too and it is still there in 8.1 Lightroom Classic release. It hogs up crazy amounts of RAM while doing simple things like preview generation, or image publishing to disk (and I am not talking heavy editing here).  I am saying like 10Gb of RAM plus 5 compressed memory on Mac OS Mojave. This is ridiculous, one has to restart it several times a day just to make it usable since it slows down as you keep using it. When will anybody at Adobe finally come to terms and address the issue? We pay subscription you know!
Photo of Tristan S

Tristan S

  • 2 Posts
  • 3 Reply Likes
I'm having some serious memory leak issues too. I open Lightroom, select a folder with ~2000 photos, select Metadata -> Read metadata from File. When finished, Lightroom uses 45 GB of RAM and needs to be restarted. (Lightroom 8.1 Mac version)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6186 Posts
  • 1371 Reply Likes
We’ve seen instances where malformed catalogs can cause excessive memory usage. To test this hypothesis please try the following.
  1. Select All Photos in Catalog Panel of Library Module
  2. [Ctrl/Cmd]+[A] to select all
  3. Right-click on any photo and select Stacking>Expand All Stacks
  4. [Ctrl/Cmd]+[A] to select all again
  5. File>Export as Catalog...
  • Save As: TestHighMemoryUsageCopy
  • Where: Desktop
  • Do not check  Export Negative Files or Build/Include Smart Previews
  • Check: Include available previews

Open the TestHighMemoryUsageCopy.LRCAT file in Lightroom and attempt the same operation(s) that caused the high memory usage.

Does the high-memory usage repeat with the test catalog?

Photo of Tristan S

Tristan S

  • 2 Posts
  • 3 Reply Likes
That fixed it in my case! I tested with a folder tree that contains 22,000 images successfully. Thank you Rikk!
Photo of Katrin Serova

Katrin Serova

  • 6 Posts
  • 5 Reply Likes
Thank you for the procedure Rikk, I will try it later today.  I do catalog optimization regularly, and it works with no errors. 
Wouldn't it be more proper for such an expensive product as Lightroom to be able to automatically fix "malformed" catalogs, or at the very least detect such errors and suggest the export/rebuild procedure?
P.S. Your "export as catalogue" procedure COULD be a viable option to refresh your main catalogue structure IF Lightroom had an option to retain all the publish services structure as part of the exported catalog. Sadly now this feature is sorely missing (why did LR developers chose to ignore the fact that some users have huge amounts of publish services configured, and would certainly like to have an option to export them, is beyond me!)
Photo of Ramona Boston

Ramona Boston

  • 35 Posts
  • 1 Reply Like
I do think Katrin is onto something here. It would be great to have a product that could manage the size of catalogs they claim to be able to handle without corruption. Especially since the official advice given is to store everything in one catalog. I'm here checking this morning because I"m once again trying to build a catalog by adding and leaving it run overnight. Doesn't work because the add process eats up too much memory. It's not even about paying a monthly fee, it's about the loss of time and work.If you want to claim to build professional tools you should build professional performance.
Photo of Ruby k

Ruby k, Employee

  • 23 Posts
  • 14 Reply Likes
Thanks for reporting issue. We have noted all the observations and working on it.
Photo of martijn Saly

martijn Saly

  • 214 Posts
  • 29 Reply Likes
I have a hard time believing this.
You could give your reply some struts and foundation by explaining what the dev team has found, what the status is, and what you are planning to do to fix this.

Since this problem has existed as of Lightroom 5.0 at least, you owe us one hell of an explanation.
Photo of Henning Metzlaff

Henning Metzlaff

  • 1 Post
  • 0 Reply Likes
I have had that memory leak issue for a long time and it's getting worse. If I just toggle around in grid view it eats up more and more memory with each klick until I have to restart lightroom again. And it never gives memory back. I am running lightroom 8.4 on an AMD RYZEN 7 2700x 8 core procesor and 32 GB RAM. I have tried all possible suggestions I could find anywhere - to no success. Also a different PC made no change. I wonder if this will be addressed by Adobe.
Photo of Mark Jones

Mark Jones

  • 1 Post
  • 0 Reply Likes
Can't even do the solution without having to reset my PC. Adobe, I'm sick and tired of losing days of work finding solutions to problems that are years old and other people have had to find work around for. The minute I have time I'm looking for alternative software.
Photo of Jose Quiroz

Jose Quiroz

  • 1 Post
  • 0 Reply Likes
I started having this issue a couple of days ago after more than 12 years of using Lr. Contrary to most of you, I use one catalog per project as it works better for the kind of photography I do, it also helps with back ups as I back up the catalog with each project and it keeps the relative path to the images. As long as I have all my folders organized, it's easy for me to find the picture I'm looking for and its respective catalog. Anyway, I have a small project (and catalog) of no more than 100 images and not even a week old. I'm using a less than 2 year old top of the line MacBook pro, over $4000 when new. Everything was dandy until I started playing with a slideshow. I did a few tests getting to know the module, a few exports as video, all good. I think here's where I updated to the latest Lr Classic v9.0 Then I started playing with adding soundtrack, one track... OK, then replaced that one for a trimmed version and then I added another track on top, previewed it, and I'm pretty sure here's the first time I noticed something wrong. I got the Mac Os warning about programs using too much memory, and was showing Lr in a "non responding" status with over 100GB of Application Ram. Then that situation starting repeating itself everytime, climbing to over 50GB of RAM within 3 minutes of starting the catalog and just letting it go idle.
Things I tried:
Tried other catalogs, they were good, culprit was this one.
Deleting the newly upgraded catalog as to force Lr to re-create one for the old one.
Deleting the previews and temporary files left behind after force quitting.
Opening Lr and closing it quickly before the RAM usage went over 5GB so it would come to terms with its temporary files
Deleting the slideshow
No luck.
I got suspicious about the soundtrack. I removed the tracks I was using and that were kept as part of the default template in the Slideshow module, closed Lr quickly before RAM usage went crazy.
Opened it again, RAM was happily around 600MB, added the original track, and after 10 minutes of playing with it and let it idle, RAM still sits at ~630 MB.
Hardly your case guys, but hopefully that will give Adobe some free troubleshooting facts to help fixing the issue. 
I hope that sheds some light.