Lightroom CC mobile: problem deleting pictures

  • 1
  • Problem
  • Updated 6 months ago
  • (Edited)
I ran into very unpleasant situation recently. I was marking my photos with flags on my cell phone. After marking some of the photos with "reject" flag, I went into "All Photos", clicked on filter icon, selected Rejected. Only flagged images came out. Then I clicked select and select all in order to delete those not very good pics. Pressed delete, confirmed. Nothing happened. I thought I might have missed the button. So I ensured there are still only those rejected pics in filtered selection, clicked select all again, pressed delete, confirmed and watch ALL MY PHOTOS disappearing. I was super lucky to spot this very fast and switch my phone into flight mode to prevent sync of those changes. For sure I completely uninstalled the app and installed again. I lost none of my pics only thanks luck and speed of my actions. I want this to never happen again.
Photo of Jaroslav

Jaroslav

  • 66 Posts
  • 15 Reply Likes
  • Angry

Posted 6 months ago

  • 1
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 216 Reply Likes
Hi,

The delete function works in a different order than you might expect. First you choose "delete" then you select the images to delete.

Here is how it should work. 

After you displayed the rejected pictures you pressed the ellipsis in the top right corner and chose "delete", is that correct?

If that is true, then at that point you need to click on the images you want to delete then click the trash can in the top right corner to delete those images. You can also swipe across multiple images to select them. 

I'm not sure how you were able to "select all" but I have a feeling you selected all the images in your library which caused the issue.

Does that help?

Rick
Photo of Jaroslav

Jaroslav

  • 66 Posts
  • 15 Reply Likes
And I wasn't clear enough. My bad, Rick.
Photo of Archana Pandey

Archana Pandey, Employee

  • 3 Posts
  • 0 Reply Likes
Could you please send across a screen recording of the issue?
Photo of Andrew Barnes

Andrew Barnes

  • 35 Posts
  • 20 Reply Likes
A screen recording of Jaroslav deleting his whole library, and quickly going into flight mode?! I’m not sure that’s something you want to be doing again!
Photo of Jaroslav

Jaroslav

  • 66 Posts
  • 15 Reply Likes
I am definitely not going to do that again. Not with my account and pictures!
Photo of Archana Pandey

Archana Pandey, Employee

  • 3 Posts
  • 0 Reply Likes
My bad..I actually wanted to check in the screen recording if the Number of rejected images selected for deleting is not same as "All Photos" 
I am sharing the link for the video with the steps , which works fine for me i.e., only selected images(rejected images) are getting deleted.
Do let me know if i have missed anything?
https://www.dropbox.com/s/v89qodbj9tp1qr8/RejectedPhotosVid.mp4?dl=0
(Edited)
Photo of Jaroslav

Jaroslav

  • 66 Posts
  • 15 Reply Likes
Well I did try it again (with active Flight mode)!

1. I go to All Photos
2. Tap o filter, apply filter (filter icon turns blue meaning it's active)
3. Click three dot menu
4. Choose select
5. Click three dot menu
6. Choose select all
7. Press Trash icon
8. Confirm deletion
9. Filter icon is still blue as active even if there is not any photo matching criteria left, it show all other photos instead
10. No if I select all again, it chooses all the photos. With filter icon indicating that filter is active.

May be I was on some low signal with slow internet and after step 8 photos did not disappear immediately encouraging me to repeat the steps, causing (along with false active filter indication) deletion of all photos instead of just filter selection.
(Edited)
Photo of Praveen

Praveen, Employee

  • 11 Posts
  • 4 Reply Likes
Dear Customer, 

Thanks for letting us know; that you are able to reproduce this issue. We tried but we are not, hence I will request you that as you know steps now; can you please share a screen recording of reproduction steps (that will be really helpful for us); as you already mentioned that you can go to flight mode and screen record this issue(without loss of your photos :)) and share with us on LrAndroid-Feedback@adobe.com
so that we can try to repeat steps and communicate with you further on this issue and probably fix this.

Thanks for your efforts. We appreciate your involvement and efforts.

-Praveen