Photoshop: Can't see selection edges (marching ants) after drawing marquee

  • 1
  • Problem
  • Updated 1 month ago
  • Solved
  • (Edited)
When I make a selection in photoshop 2018 using the marquee tool the edges are not visible. I have to click in the marquee box in the toolbox and then they become visible. This is across a number of machines using Sierra on Macs.
Photo of Virginia O'Cleirigh

Virginia O'Cleirigh

  • 11 Posts
  • 2 Reply Likes

Posted 1 year ago

  • 1
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2188 Posts
  • 904 Reply Likes
I'm sorry, but what 'marquee box in the toolbox' are you talking about?
Photo of Virginia O'Cleirigh

Virginia O'Cleirigh

  • 11 Posts
  • 2 Reply Likes
Rectangular Marquee Tool
Photo of Virginia O'Cleirigh

Virginia O'Cleirigh

  • 11 Posts
  • 2 Reply Likes
Marching ants not visible after a selection is made until the Rectangular Marquee Tool is clicked again in the toolbox and then they show up.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15586 Posts
  • 2346 Reply Likes
Have you tried restoring your preferences? Restore preferences
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2188 Posts
  • 904 Reply Likes
As the OP hasn't come back on this, I get the feeling that it was user error and that she found that out by now.
Photo of Virginia O'Cleirigh

Virginia O'Cleirigh

  • 11 Posts
  • 2 Reply Likes
I tried restoring preferences and it didn't do anything. No it wasn't user error as it can be replicated across a number of machines as previously stated. 
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2188 Posts
  • 904 Reply Likes
User errors can be replicated too, obviously. You still haven't explained exactly what the problem is. Everybody seems to be guessing. What is this 'marquee box in the toolbox' you are talking about?
(Edited)
Photo of Virginia O'Cleirigh

Virginia O'Cleirigh

  • 11 Posts
  • 2 Reply Likes
It's fairly simple, look at the tool box. There is a Rectangular Marquee Tool at the top. It looks like a box. I can't see any other marquee box tools in there...

Marching ants not visible after a selection is made using this tool the until the Rectangular Marquee Tool (marquee box in the toolbox)  is clicked again with a mouse or a tablet (in the toolbox) and then the selection edges (marching ants) show up on your document.

I think that explains it...
(Edited)
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2188 Posts
  • 904 Reply Likes
OK, so you mean the tool panel. Yes, that explains it but I can't reproduce it.
Photo of David

David, Official Rep

  • 3263 Posts
  • 521 Reply Likes
Howdy Virginia,

If you click the View entry in the Menu Bar, is there a check mark to the left of Extras?

Thanks,
David
Photo of Virginia O'Cleirigh

Virginia O'Cleirigh

  • 11 Posts
  • 2 Reply Likes
Hi David. Extras is clicked on. 
(Edited)
Photo of Virginia O'Cleirigh

Virginia O'Cleirigh

  • 11 Posts
  • 2 Reply Likes
This issue never manifested with 2017. It did however with a previous version, the original CC if I remember rightly until an update fixed it. I'll just keep all machines on 2017 and periodically check to see if the issue has been fixed in future updates. 
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15586 Posts
  • 2346 Reply Likes
Would it possible to do a screen caputure video to see the behavior/steps you’re doing?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15586 Posts
  • 2346 Reply Likes
It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help > System Info... and copy/paste the text in a reply.
Photo of David

David, Official Rep

  • 3263 Posts
  • 521 Reply Likes
Howdy Lee and Ginta,

Can you each do me a favor?  Can you share with me your basic system setup?  Which OS and version?  Any other additional PS plugins installed (like Topaz or Alien Skin)?  What kind of video card do you have?  Have you tried playing with the GPU settings?

Thanks,
David
Photo of Lee Philo

Lee Philo

  • 6 Posts
  • 1 Reply Like
Hi David

OS 10.12.6
2013 Mac Pro
3.7 GHz Quad-Core Intel Xeon E5
AMD FirePro D300 2048 MB

On1 Photo Raw

Yes I have tried different GPU settings, restarting each time.

This problem came and went with the last couple of rounds of updates.

Thanks
Lee
Photo of David Pastirchak

David Pastirchak

  • 4 Posts
  • 2 Reply Likes
New version photoshop online yesterday! Problem solved! Nice to see where I’m masking now!
Photo of David

David, Official Rep

  • 3263 Posts
  • 521 Reply Likes
Howdy David and Lee,

David, thanks for that info.  Awesome!

Lee, does the update solve the problem for you?

Let us know,
Thanks,
David
Photo of Lee Philo

Lee Philo

  • 6 Posts
  • 1 Reply Like
Hi David
Yes, it appears the problems discussed are fixed.  Thank you!
However, the lasso tool has developed a similar problem.  It is behaving erratically on existing files, yet seems fine on new files.
Many thanks
Lee
Photo of jenkins2541

jenkins2541

  • 1 Post
  • 1 Reply Like
For what it's worth, resetting the photoshop preferences worked for me.
I was seeing strange purple guides as I dragged the marquee tool, rather than the marching ants that I'm used to. The guides seemed to be pointing me to perfect center.

I used this method: 1.) Quit photoshop.  Restart photoshop from the dock in mac holding down command-option-shift. It asked if I'd like to restore preferences to default.
Photo of Will B

Will B

  • 1 Post
  • 0 Reply Likes
I am on Mac OS 10.14 and I have had the same viewing issues, as in when click and dragging a selection area, the "marching ants" does not appear until I have stopped my selection. And also, when using transform tool, the transform handle box lingers after the action has been performed, it only disappears when I zoom in or out of my view. Selecting another tool did not clear the artifact. 

Resetting my preferences per Jenkins2541 did correct both issues.
Photo of Gary Chan

Gary Chan

  • 1 Post
  • 0 Reply Likes
I've tried all the above and still doesn't work for me, resetting, reinstalling and all, I still don't see the selection when I select with the lasso tool.... this is fxxk up 

(Edited)
Photo of David

David, Official Rep

  • 3130 Posts
  • 491 Reply Likes
Hi Gary,

What version of Photoshop are you working with?  On which Operating System?  Have you tried trashing your Photoshop preferences file on startup?  Have you gone to the View menu and made sure that Extra has a check to the left of it AND that under Show you also have a check to the left of Selection Edges?

Thanks,
David
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15411 Posts
  • 2260 Reply Likes
Are you working on CMYK images? If you open or create an RGB image and then go back to your CMYK files, does the selection edges draw?
Photo of Kathleen Mohr

Kathleen Mohr

  • 1 Post
  • 0 Reply Likes
Same problem, can't see selection area 'marching ants' when making a selection, only after I've double-clicked to stop selecting. I've tried resetting my preferences and checked the View settings. Agree with Gary, this is fxxk up. Mac OSX 10.12, Photoshop 20.0.1. Kathleen
Photo of Cheryl Krawczyk Cravino

Cheryl Krawczyk Cravino

  • 1 Post
  • 1 Reply Like
Same Issue no selection edges when using the lasso tool until I let go. :( Reset my preferences, clean restart still nothing.
MAC OS Mojave 10.14.3
Photoshop CC 2019
tried all suggestions above to no avail......however if I switch from CMYK mode to RGB mode they are there!
Work around: Make selections in RGB and then back to CMYK......clearly not the proper way to work on images!
This needs a fix!
Photo of Ceci Good

Ceci Good

  • 2 Posts
  • 0 Reply Likes
What if you turn off "Use Graphics Processor" in Preferences>Performance? Top right of window. You'd have to restart photoshop. Just a guess, but this helped me when I was having trouble getting my selections to show the selected area.
Photo of Greg L

Greg L

  • 1 Post
  • 0 Reply Likes
Turning off "Use graphics processor" Takes away the pen tools options in the preferences. Is there a way to have the poly lasso tool show its path, and still have the pen options available?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15503 Posts
  • 2305 Reply Likes
Did you try leaving on Use Graphics Processor and opening an RGB file to have the extras show on a CMYK document?
Photo of Ceci Good

Ceci Good

  • 2 Posts
  • 0 Reply Likes
I just checked, my "Use graphics processor" is back on again and I can still see the selection edges. Possibly you just need to toggle it off and restart photoshop and then turn it on again? I also turned off (in Preferences > Performance > advanced settings) "anti-alias guides and paths". When I turned it back on again after restarting photoshop, my selection edges were still working.