Photoshop: CS6 Extended 3D features not working

  • 6
  • Problem
  • Updated 12 months ago
  • Solved
  • (Edited)
I am unable to use my 3D tools. I have tried with an image from Illustrator, and with typing text and then applying 3D. The options in the drop down box cannot be selected. I have Photoshop 6 extended. Does any one have any idea? Is there something in my settings stopping me?
Photo of sherrie courtney

sherrie courtney

  • 3 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 6
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 20249 Posts
  • 666 Reply Likes
Are any of the 3D features enabled?

Is your GPU disabled for some reason?
Photo of sherrie courtney

sherrie courtney

  • 3 Posts
  • 0 Reply Likes
the only feature enabled in the drop down box is the 'get more content' option. I think the GPU is enabled ( i can make the 3d options work in Illustrator so am assuming the gpu is working although my knowledge of all this is limited)- this problem I am having is inconsistent - when I first started yesterday, I could access many of the options, but then I ctrl z what i had done, and then couldnt access anything. So I deleted the file and started again, as I had the first time, and nothing worked. Even shut down and reopened photo shop.
Last week when I first tried, nothing seemed enabled. The IT guy thought maybe extended had not downloaded properly. and then the next time we opened it, the options were enabled. On one occasion, if I imported a picture first, and then copied in the graphic from illustrator, the 3d options were enabled. but not without the background picture (background layer still there, just blank).
It makes me think that i am inadvertently changing some thing as I work, and not knowing enough about it, dont know what to fix, and cant find any help... Searching yesterday i came across a tute that was just making text 3d, and following the steps exactly, still had the same problem with the drop down box tools not working.
Photo of sherrie courtney

sherrie courtney

  • 3 Posts
  • 0 Reply Likes
Hi Chris. Thanks for your help with this.
So, re 3D menu being enabled – I do have Photoshop extended installed. 3D does appear in preferences and I can change the settings.

In Performance the graphics processor is enabled but if I go into advanced settings, drawing mode is basic and I am unable to change that. and in the four bottom options, I am only able to change the anti alias and 30 bit display – I don’t know if this means anything to you.

Photo shop help system info did not show any errors
I am using Windows 7.

Could it be the video card? (except that I could sometimes start using the 3d tools, just not consistently.
Could it be not enough RAM? However we have just tried using the same Ai doc in photoshop on another computer with 8g RAM and having the same problem on that.
Is there something else we need to do to enable? But then, why did it work some times?
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 20249 Posts
  • 666 Reply Likes
Yes, you either have a very underpowered video card, or a problem with the drivers that makes Photoshop think it is less capable than it should be.

What GPU do you have?
Have you updated the driver from the GPU maker's website?
And how much memory is listed for that GPU in the Photoshop Help -> System Info log?
Photo of Anant Mukim

Anant Mukim

  • 1 Post
  • 0 Reply Likes
I am facing the same issue and I'm using a desktop with 8GB RAM, a 3rd Gen Core i5 and the AMD Firepro v4800 with 1GB DDR5 RAM. I have enabled photoshop to access 100% of the 1GB VRAM and 4GB of PC RAM.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 20249 Posts
  • 666 Reply Likes
Your card should be capable, but you need to check the driver - and the Help->System Info log might tell you why your current driver is not working.
Photo of Janine

Janine

  • 1 Post
  • 0 Reply Likes
I have just found that if you have anything but the Move Tool selected you can't see the 3D Tool.
Photo of don gallucci

don gallucci

  • 2 Posts
  • 0 Reply Likes
I have the same problem, and it always worked before. I love working in 3D so it's very upsetting. I did update the driver to the newest for my cards. It seemed to happen at about that time or when I downloaded the last PS update. Is there anyway to resolve this? Preferences seem to be set correctly. I would greatly appreciate any suggestions.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 20134 Posts
  • 641 Reply Likes
More information would help: OS version, GPU, how much VRAM, etc.?
Did you install all the Photoshop updates?
Did you update your video card driver from the GPU maker's website?

Looking at the GPU section of the Help -> System Info log should also tell you a bit more.
Photo of don gallucci

don gallucci

  • 2 Posts
  • 0 Reply Likes
I realized that I no longer had enough vram to meet the requirement. So, I deleted the update and replaced it with the original release. I have 6GB of ram but only about 375vram and I think the current requirement is 500mb vram. I think that it was a bad decision just based on the number of complaints that I see. Bad decision. I can't use any new updates until I buy a new computer. Bad decision.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 20134 Posts
  • 641 Reply Likes
No, it was a necessary change to prevent problems: with less than 512 Meg, the 3D features have problems due to issues in OS code and many drivers. The stated requirement was 512, and the 3D features allowed 256 for a while - but found that it caused more problems than it solved (again, because of external issues ) and put the requirement back to 512 Meg to prevent all those problems.
Photo of Charley Bell

Charley Bell

  • 1 Post
  • 3 Reply Likes
Make sure your color mode is set to RGB, and not CMYK.
Photo of tanya lyons

tanya lyons

  • 1 Post
  • 0 Reply Likes
THIS IS THE ANSWER!
Photo of Martin Bradley

Martin Bradley

  • 1 Post
  • 0 Reply Likes
OMG thanks!!
Photo of Coen Scott

Coen Scott

  • 1 Post
  • 0 Reply Likes
I went into colour settings (ctr + shift + k) and couldn't see an option to set the colour to RGB. Under working spaces, there is an RGB and CMYK setting pannel is this the right place?
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 20134 Posts
  • 641 Reply Likes
Colorsettings has nothing to do with it.
Check the color mode of your document.
Photo of Lee Attwood

Lee Attwood

  • 1 Post
  • 0 Reply Likes
Nice one charley, fixed, bit of a Doh!! moment when I realised I was in CMYK
Photo of domhnall

domhnall

  • 3 Posts
  • 0 Reply Likes
I have this problem all the time. And it is a driver/software conflict of some sort, because all of a sudden, it will just stop working. I am not sure why it happens. Maybe somebody updated something on my machine or something like that, but it is a huge pain. So much that after installing the latest video drivers, should that fail, I usually just give up, and then 3 months later it is magically working again. Maybe it is a conflict between Houdini or Premiere or if I am using logmein remotely, but whatever it is, it is definitely not because my video card is underpowered.
Photo of Valerie DeLeon

Valerie DeLeon

  • 2 Posts
  • 0 Reply Likes
Are you in RGB color mode?
Photo of domhnall

domhnall

  • 3 Posts
  • 0 Reply Likes
Yep.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 20134 Posts
  • 641 Reply Likes
LogMeIn has caused problems like this before - by claiming different (lesser) capabilities for the GPU.
Photo of domhnall

domhnall

  • 3 Posts
  • 0 Reply Likes
Sorry, I never replied, but yes, thank you. It was LogMeIn. If the problem happens again, I just kill logmein and restart Photoshop and that usually does the trick.
Photo of Alex Hazen

Alex Hazen

  • 5 Posts
  • 0 Reply Likes
Color mode setting has to be RGB
Photo of ammar

ammar

  • 1 Post
  • 0 Reply Likes
hello every one
i faced the same problem but .
i solved it by installing a new driver for graphic driver and i enabled 3d in driver controller

i have GeForce 8600 GT DRIVER , win7 64bit

AND IT IS DONE WILL
THANKS