Photoshop: Jaggy Select Subject Edges

  • 2
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
Using Select Subject is creating unusable edges... is this intended?

No matter what the subject is or if auto-enhance is on/off, this is what the edges look like:



for some reason, Select Subject is working at a very low resolution.
Photo of eartho

eartho

  • 799 Posts
  • 194 Reply Likes

Posted 2 months ago

  • 2
Photo of Meredith Payne Stotzner

Meredith Payne Stotzner, Employee

  • 67 Posts
  • 9 Reply Likes
We're not able to reproduce that in-house on 19.1.4 or older released builds.
I noticed you're in the Prerelease program.
Is there a chance you've launched an experimental build?Thanks,Meredith
Photo of Walter Gronli

Walter Gronli

  • 8 Posts
  • 4 Reply Likes
A workaround could be to use >Select >modify >smooth - before masking or deleting background.
Photo of TangCanada

TangCanada

  • 21 Posts
  • 3 Reply Likes
See menu options at top ... tolerance is set too low.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1177 Posts
  • 315 Reply Likes
There are no tolerances for Select Subject. So I'm not sure what TangCanada is referring to.

That said — I'm not seeing aliasing in the Release version. Granted, it still isn't terrific, but it's not aliased like that. I do still need to go into S&M to torture myself with refining the edges, but I'm most certainly not starting out at that horrible a level. I'd upload a JPEG screenshot, but the site says it can't process it. It's only 25KB at ~600x600 pixels. Hey ho. Just take my word for it. <g> It's not aliased, even at 200 percent.

Photo of TangCanada

TangCanada

  • 21 Posts
  • 3 Reply Likes
Using the majic wand tool, not the quick selection, you will see on the options bar to set tolerance...
Photo of eartho

eartho

  • 799 Posts
  • 194 Reply Likes
Tang, this issue isn't about the magic wand or quick select, i'm pointing out a problem with the Select Subject tool in the options bar.
Photo of eartho

eartho

  • 799 Posts
  • 194 Reply Likes
Hey Cristen, i tracked it down to an issue with the GPU. When active, i get those nasty edges, but once i deactivate the pref, the issue goes away.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1177 Posts
  • 315 Reply Likes
> i tracked it down to an issue with the GPU>

Ouch. I hope it's a bug and not your video card becoming unsupported. I dread the day that happens here if it's earlier than Apple releases another model or two to give me a choice in new computers. As it is, I got the message from Nvidia to upgrade my driver, did so, and now every launch I get the same screen saying I'm to update—but also saying no newer driver is available. If I didn't love what I can do with computers, I'd hate them.<G>
Photo of Meredith Payne Stotzner

Meredith Payne Stotzner, Employee

  • 67 Posts
  • 9 Reply Likes
There are two "me too" clicks on this Feedback subject.
If you are experiencing this issue with Select Subject, please:
  • •Post your system info (Photoshop: Help > System Info... [Copy])
  • •Turn GPU off (Photoshop: Preferences > Performance... uncheck "Use Graphics Processor"), reopen the image file and try Select Subject again. (Don;t forget to turn it back on later :> )
Please reply with your system info and with the results of GPU off made a difference.Thank you,Meredith