Getting a program error with Select and Mask

  • 4
  • Question
  • Updated 7 months ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Photoshop CC 2018: After latest update, "select and mask" tool gives program error

select and mask not working, getting an error message saying: COULD NOT APPLY THE WORKSPACE BECAUSE OF A PROGRAM ERROR

Please advise
Photo of peter smart

peter smart

  • 1 Post
  • 0 Reply Likes

Posted 7 months ago

  • 4
Photo of Ben Hoskins

Ben Hoskins

  • 1 Post
  • 1 Reply Like
I'm getting the same. Restarting, shutting down, clearing memory. 
Photo of Jerry Syder

Jerry Syder

  • 180 Posts
  • 88 Reply Likes
It's also extremely slow on my end. Windows 10, NVIDIA(latest drivers), 32GB Ram. 
Photo of Stephen Newport

Stephen Newport

  • 261 Posts
  • 66 Reply Likes
This happens for me anytime I initiate Select and Mask on a selection. If I turn that selection into an alpha mask it works as normal on the mask.
 
Another error that has popped up for this same issue is:

"Could not load keyboard shortcuts because of a program error"


Can someone from Adobe please respond?
Photo of Hannah Nicollet

Hannah Nicollet, Official Rep

  • 561 Posts
  • 212 Reply Likes
There is another thread where users are suggesting that changing to 8 bit is a workaround, but I haven't heard back yet about their version.
Photo of Stephen Newport

Stephen Newport

  • 261 Posts
  • 66 Reply Likes
I can confirm 8bit works as expected on my system, unfortunately I don't have the option to work in 8bit for my projects so I'll have to do it the slow way until a fix is released.
Macbook Late 2016, Updated everything.
Photo of Hannah Nicollet

Hannah Nicollet, Official Rep

  • 561 Posts
  • 212 Reply Likes
Hi Peter,

Do you have a channel selected when you attempt the Select and Mask?
Photo of Hannah Nicollet

Hannah Nicollet, Official Rep

  • 561 Posts
  • 212 Reply Likes
Is this with CC2018? What OS are you using?
Photo of Stephen Newport

Stephen Newport

  • 261 Posts
  • 66 Reply Likes
2018 here, High Sierra
Photo of Stephen Newport

Stephen Newport

  • 261 Posts
  • 66 Reply Likes
Uncheck "remember settings" in select and mask dialogue. This worked for me. You can recheck it later
(Edited)
Photo of Hannah Nicollet

Hannah Nicollet, Official Rep

  • 561 Posts
  • 212 Reply Likes
You were able to get smoothing to remain disabled on a new launch this way?
Photo of Stephen Newport

Stephen Newport

  • 261 Posts
  • 66 Reply Likes
No, this only solved the "select and mask" error. Smoothing still turns itself back on upon restart (however it remains at 0% for me)
Photo of Hannah Nicollet

Hannah Nicollet, Official Rep

  • 561 Posts
  • 212 Reply Likes
Okay thanks. We still need a file to test that is encountering the problem. Any of your files that are causing the program error would be great to have.

Thanks,
Hannah

This conversation is no longer open for comments or replies.