Elements 14: Screen flicker on Windows

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Just installed Photoshop elements 14, am now having screen flicker and ocassional black screen. All drivers are the latest version. asus 9400gt with driver ver. 340.52. cpu drivers are updated also.
Photo of Bill Weiss

Bill Weiss

  • 5 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14679 Posts
  • 1958 Reply Likes
Hi Bill, What specific video card to have? Did you use Windows Update to check for the latest driver? Or another method?
Photo of Bill Weiss

Bill Weiss

  • 5 Posts
  • 0 Reply Likes
Was away from computer for awhile........EVGA 1gb 9400GT. It all started as soon as I began the install off of the disc. Immediately during install I had a lot of flicker. It lessened some after that, but then the screen will go black momentarily. Had no problems before installing Photoshop 14. I even did a complete uninstall of everything that was included with the disc, but I still have the flicker problem now.
Photo of Bill Weiss

Bill Weiss

  • 5 Posts
  • 0 Reply Likes
Sorry forgot to mention driver is version 341.44.,,,,,,my bad....I was assuming the video card was asus....(asus motherboard, asus monitor etc). I just went to Nvidia's website and downloaded latest driver, (ver 340.52). I will let you know in a while it this takes care of the flicker pro blem.
Photo of Bill Weiss

Bill Weiss

  • 5 Posts
  • 0 Reply Likes
Still having flicker and momentary black screen. Updating to latest nvida version 340.52 has not resolved any issues.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14679 Posts
  • 1958 Reply Likes
Ok. That was going to be my suggestion. Grabbing the latest driver directly from the manufacturer usually solves most video glitches. Let us know if that doesn't solve it.
Photo of Bill Weiss

Bill Weiss

  • 5 Posts
  • 0 Reply Likes
reverted back to older driver version with clean install, did not work, updated to each newer version with clean install, still didn't work. This is a new asus pa248q monitor which has shown this type of problem. The interesting thing is that it worked fine until I inserted the Photoshop software disc. It immediately started flickering like crazy during the install process. I have since hooked my old monitor back up and it works fine. Something in the program obviously triggered the flickering glitch. (I do not have the Photoshop program loaded anymore as I have removed it). This is an older computer, 2009 era, intel q9550 cpu, with 4gb ddr2 ram, NVidia 9400gt card and I think this graphics card may not be compatible with the new Photoshop program. Do you know for sure if this type of system has worked with Elements 14? Am sending monitor back to Amazon because it is within 30 days of purchase. Thanks for your help Jeffrey.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
The installer doesn't use the GPU, or run any of the application code.

From your description, there is something wrong with your system, video card, or display.