Photoshop: Scaling down and rotating Smart Objects creates jagged edges

  • 4
  • Problem
  • Updated 9 months ago
  • (Edited)
When scaling down a Smart Object and rotating it, subtle but significant aliasing occurs. This does not occur when doing the same thing to a regular raster layer, nor does it seem to occur when only scaling or only rotating the Smart Object.

To illustrate the problem, I have attached two pictures. Each one is of the same graphic, scaled down and rotated.

Here, the raster layer produces the expected results (clean, slightly soft edges with little aliasing). But the Smart Object produces small but significant stair-stepping, even though it *should* in theory produce better results.

This problem occurs no matter what interpolation method is selected in Preferences. These examples were both scaled down using Bicubic Smoother, which produces the least bad results. When using Bicubic, Bilinear, or Bicubic Sharper, the problem is worse.

The graphic being used is of a high resolution (6000x9330) scaled down by nearly 50%. This should be more than enough to produce smooth edges (and, in fact, it is when scaled/rotated as a normal raster layer).

Modern Photoshop is built around Smart Objects, and yet it produces awful results when scaling and rotating. What’s the deal?

System information:
2018 Retina MacBook Pro
Intel Iris graphics
MacOS Catalina 10.15
Photoshop CC 20.0.7 (though this affected at least two versions before it)


Photo of MS_design

MS_design

  • 5 Posts
  • 3 Reply Likes
  • frustrated, confused, perplexed

Posted 10 months ago

  • 4
Photo of Max Johnson

Max Johnson, Champion

  • 624 Posts
  • 338 Reply Likes
An option in the properties panel for smart object layers to define which interpolation method to use would be excellent.
Photo of MS_design

MS_design

  • 5 Posts
  • 3 Reply Likes
Burying Smart Object interpolation in the General section of Preferences IS stupid, but, like I said, this problem occurs regardless of the interpolation method being used.
Photo of Max Johnson

Max Johnson, Champion

  • 624 Posts
  • 338 Reply Likes
Can't confirm, but I think the General Preferences resize method is only for raster transform and smart object scaling is ALWAYS bicubic
Photo of MS_design

MS_design

  • 5 Posts
  • 3 Reply Likes
No, it applies to Smart Objects as well.
Photo of MS_design

MS_design

  • 5 Posts
  • 3 Reply Likes
I went ahead and made a gif to make the disparity between raster layer and Smart Object scaling more obvious.

Photo of MS_design

MS_design

  • 5 Posts
  • 3 Reply Likes
I did some more testing and this occurs with both PDFs and raster images converted to or imported as Smart Objects. This doesn't occur when using .AI files directly.

This is strange, since PDFs and AI files, both being vector-based, should produce identical results.