Save for web key-combo misbehaves

  • 1
  • Question
  • Updated 5 years ago
German language version; US Keyboard;

Initiating Save for web by pressing CMD-ALT-SHIFT-S moves my current layer to the top instead. What goes wrong there?
Photo of Christian Hofmann

Christian Hofmann

  • 2 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of David

David, Official Rep

  • 2716 Posts
  • 373 Reply Likes
Is your keyboard actually set to English for your OS? In other words, so you see the little American or British flag up in the top right of the Command menu?

Are you running any other applications which interact with pointing devices (mouse, trackball, usual keyboard, etc)? How about actual devices?
Photo of Christian Hofmann

Christian Hofmann

  • 2 Posts
  • 0 Reply Likes
Thanks for your reply. I found out the reason - yes, basically it's correct: my Keyboard is set to US in Mac OS.

Photoshop, however, has a strange setting, as "move layer to front" is triggert by cmd-shift-ß, and ß is produced by pressing option-s. So basically, it seems impossible to use a German Photoshop with a US keyboard.
Photo of David

David, Official Rep

  • 2716 Posts
  • 373 Reply Likes
Hiya Christian,

Uh, what version of Photoshop are you using? In the latest version, the command on Mac to "Move Layer to Front"/""Ebene nach oben verschieben" is CMD+SHIFT+ä per http://help.adobe.com/de_DE/photoshop... . Now, that said, this results in the same problem since this letter also don’t exist on an English keyboard, but this command is fully customizable via Edit > Keyboard Shortcuts. So you could always change it to a combo that includes a letter which is accessible from a US keyboard.

The expectation for non-English users is that they are mostly likely also using a non-English keyboard. Thus there is a separate set of shortcuts for each language. If you want to use the US keyboard with the German version of the application, I would suggest using the US keyboard shortcut map. You can find all the languages at http://helpx.adobe.com/en/photoshop/k...

Thanks,
David
Photo of Christian Hofmann

Christian Hofmann

  • 2 Posts
  • 0 Reply Likes
Thanks, that solved my problem - now shortcuts behave as they should...

As to your question: I'm using a "virgin", i.e. unmodified, version of Photoshop CC freshly installed from the cloud after first uninstalling the previous version (also installed from the cloud). Maybe the previous uninstall wasn't all that clean and did keep some strange settings? Might be a bug, something worth for the QA to look into...

Well, it doesn't bother me now, changing the shortcut map worked out perfect! Thanks again

Chris