Save Replace not working

  • 3
  • Problem
  • Updated 8 months ago
Merged

This conversation has been merged. Please reference the main conversation: Photoshop: Saving copy not saving over jpg file

When I go save a file, that is meant to replace an already existing file, even though I hit replace, it makes a copy instead, leaving the original file there with the intended name.
Photo of Fabian Fernandez

Fabian Fernandez

  • 2 Posts
  • 0 Reply Likes
  • Annoyed

Posted 8 months ago

  • 3
Photo of Cristen Gillespie

Cristen Gillespie

  • 2051 Posts
  • 714 Reply Likes
My experience has been that when a Save As makes a copy (I assume we're talking PS here?), it says it's going to in the dialog, and I have always had some element in the file that doesn't save in the format I'm choosing. Otherwise, if I'm using Save As to replace an existing file that's not open, it always just replaces it.

So could you be more specific? Tell us your OS, your version of PS (if that's your program), and be more specific about what you've done that you're replacing an existing file with the open one? I know I replaced a file with the newest release of PS just yesterday. I'm running Mojave.
Photo of Fabian Fernandez

Fabian Fernandez

  • 2 Posts
  • 0 Reply Likes
So my main working file is saved as a photoshop file in my projects folder. Hitting save on that file simply replaces the working file as intended.

But I also save a copy of the same file as a .png to an asset folder for an already existing video project (so I can just open. that video project and export the video with the new .png asset). Here is where I run into the issue and when I tell it to replace the existing .png i'm left with "file123.png" & "file123 copy.png"

Does this make more sense?
Photo of Cristen Gillespie

Cristen Gillespie

  • 2044 Posts
  • 708 Reply Likes
> Does this make more sense?

Yes. I tried to open a PNG file, then Save As to save it as a new name. It didn't replace the PNG file that was open. I made changes, tried to save it, it saved it with xxx copy. When I tried to figure out exactly what I'd done, I lost track. I can't replicate it.

I do know it doesn't appear to be updating the file that's open. Not so long as there's a Save As involved. If I save as and replace a file, the file open hasn't been saved. If I attempt to close it, it asks me if want to save it, even though I haven't done anything since just doing a Save As and replacing another file.  And Save As always says it has to save a copy. It won't even save Untitled 1 as the name I just gave the file on the first save.

It does feel like something isn't right here. But I can't seem to pin it down to make it happen all the time. This isn't a typical workflow for me, so I haven't observed this before, but it does feel somewhat off. Unexpected.

Sorry I can't figure out more. Maybe when the weekend is over, someone will know just what is going on.

This conversation is no longer open for comments or replies.