Save for Web vs. Quick Export Permissions

  • 1
  • Problem
  • Updated 1 year ago
Originally from here, https://forums.adobe.com/message/9637637#9637637

It took me some time to figure out that Photoshop's new 'Quick Export' doesn't properly export images with the same permissions as 'Save for Web'. I saved a JPG file from PS using both methods, in the same exact folder. You can see from the image below that the Users/Groups are different. I have verified this behavior with other systems in our office.

 

problemPermissionsjpg

 

This becomes an issue when trying to serve files locally in a web browser via IIS (Internet Information Services) where a 'HTTP Error 401.3 - Unauthorized' occurs.

 

error401jpg

Is there a time-frame when this will be fixed? I'd love to use the new tool but this is a game stopper for me.

Thanks,
Craig
Photo of Craig Neering

Craig Neering

  • 4 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Max Johnson

Max Johnson, Champion

  • 488 Posts
  • 235 Reply Likes
To add some more information to this...
I wonder if this has to do with the Generator that Adobe uses for the new export... it's running a Node instance that does the file handling and that Node.exe may have different permissions than Photoshop.exe when writing to the drive? It's also possible that the convert.exe (image magik) or flitetranscoder.exe have the same issues?

All the .exe files in the /Photoshop CC 2017/ folder seem to have the same security permissions, though...