Photoshop: Save As Dialog Issues on Mac OS Catalina 10.15.3

  • 1
  • Problem
  • Updated 4 months ago
  • (Edited)
I just upgraded to Mac OS Catalina 10.15.3 and using Save As within Photoshop 21.10.0 presents these problems:
When Photoshop automatically appends "copy" to the file name during a Save As, unchecking the "Save as a Copy" button in the save dialog no longer properly deletes the word "copy" from the suggested filename.
Selecting the filename in the Save dialog box also selects the suffix (".psd" or ".jpg" for example) which is then improperly deleted when typing a new name into that text box.
Photo of joe

joe

  • 7 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Gary Cawood

Gary Cawood

  • 18 Posts
  • 5 Reply Likes
I am noticing the same problem.

Photo of Andrew Rodney

Andrew Rodney

  • 1240 Posts
  • 268 Reply Likes
I'm on Catalina too, I don't see that behavior. I see no difference in the file name with or without "Save a Copy" too. Not sure what's up here but maybe resetting the PS preferences will do the trick? 

Press and hold Option+Command+Shift (Mac OS) immediately after launching Photoshop. You will be prompted to delete the current settings.

This action only affects the items found in the preferences dialog box. Numerous program settings are stored in the Adobe Photoshop Preferences file, including general display options, file-saving options, performance options, cursor options, transparency options, type options, and options for plug‐ins and scratch disks. Brushes (and lots of other setting) are not affected by the above instructions for deleting preferences. You may wish to make a screen capture of the settings in the Preferences dialog to reset them prior to deleting of this file. 

Photo of joe

joe

  • 7 Posts
  • 0 Reply Likes
I see that Adobe has documented a similar issue -- checking the As a Copy box does not add the word copy to the filename -- but not the exact issue(s) that I'm seeing.
Photo of Andreas Steffan

Andreas Steffan

  • 12 Posts
  • 0 Reply Likes
Thank you @andrew , it has helped :)