Photoshop: Dragging image from Safari to Photoshop causes Photoshop UI to lock up.

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Drag an image from Safari to Photoshop causes Photoshop UI to "lock up".
This error has been there at least since cs6.. please fix it :).
View video here: https://www.youtube.com/watch?v=Xvp8lr...
Photo of Poulg

Poulg

  • 30 Posts
  • 2 Reply Likes
  • not a taxi driver...

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Which version of Photoshop are you using?

For CC and earlier, did you install the WhiteWindowWorkaround plugin to avoid some known MacOS issues?
Photo of Poulg

Poulg

  • 30 Posts
  • 2 Reply Likes
Photoshop CC 2.2, should be the latest release.

I did not install the WhiteWindowWorkaround, i never heard of it.

Is this a workaround because its a thing Adobe can't fix?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Yes, we can't fix OS bugs, but sometimes we can work around them.

But CC 2014 doesn't need that plugin (workarounds are already in the app).

If you are still using CC, then you need to install that plugin.

What OS version are you using?
So far I can't reproduce a hang on 10.7, 10.8, or 10.9 (and 10.10 has too many problems for me to run at home).
Photo of Poulg

Poulg

  • 30 Posts
  • 2 Reply Likes
I'm on 10.9.5
Its the version I'm running at work..
Photo of Poulg

Poulg

  • 30 Posts
  • 2 Reply Likes
CC 2014..
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1735 Reply Likes
Are you using a Wacom tablet?

Do you have more than one monitor hooked up?

Any 3rd party OS X utilities installed? They usually show up here in System Preferences:



We've seen issues with dragging layers in the following scenarios:

(iCopy - 3rd party utility)
http://feedback.photoshop.com/photosh...
http://apple.stackexchange.com/questi...
(Intuos Driver issue)
https://forums.adobe.com/message/4256...
(Synergy - 3rd party utility)
http://feedback.photoshop.com/photosh...

Try booting in safemode to disable system utilities: http://blogs.adobe.com/crawlspace/201...
Photo of Poulg

Poulg

  • 30 Posts
  • 2 Reply Likes
Check, check and check..

I have a wacom, i have 2 screens (mac Pro) i have 3rd party plugins.
I will try the safe mode boot.