Lightroom Classic CC 7.2: Rolled back to 7.1 due to lack of performance

  • 2
  • Problem
  • Updated 8 months ago
  • (Edited)
I rolled back from LR Classic 7.2 to 7.1 because of immense performance problems.

My catalogue only contains 30.000 pics and 7.1 handled them well. Not so 7.2.
Starting LR application it seemed to be OK. After working for more than 10 minutes it went slow - until nearly freezing. 

I did not use any search function because I've been warned about that. But applying keywords should not need 5 minutes until updating the screen.

My System is:
Windows 10 x64
RAM 16 GB
Intel i7
1 TB SSD containing catalogue and pics.

Maybe you can fix this with the next 7.2 update. I make my living as a photographer and have been satisfied with all LR versions except 7.2...

Regards, Klaus
Photo of Klaus Mohr

Klaus Mohr

  • 7 Posts
  • 3 Reply Likes
  • frustrated

Posted 9 months ago

  • 2
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 225 Reply Likes
Hi Klaus,

Have you tried any of the steps on this page?:

https://helpx.adobe.com/lightroom/kb/issues-lightroom-classic-7-2.html

Does that help?
Photo of Klaus Mohr

Klaus Mohr

  • 7 Posts
  • 3 Reply Likes
Hi Rick,

I already disabled/paused synchronization - before rolling back to 7.1. It didn't change the behavior of 7.2
I also had reset the LR settings by starting LR with SHIFT/ALT. No change.
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 335 Reply Likes
Klaus, it is likely you had an installation issue with your first install of Lightroom 7.2. With very few exceptions most users are reporting better performance with 7.2 than with 7.1.  If you are up for it, I would recommend that you attempt to perform a clean install of 7.2 by first removing 7.1 and then rebooting. After reboot, install 7.2 directly from the Creative Cloud app. 
Photo of Klaus Mohr

Klaus Mohr

  • 7 Posts
  • 3 Reply Likes
Thanks Rikk, it seems to work.

In case of running into the same problem after a longer time of developing pics, I'll come back to you.
Photo of Oliver Stein

Oliver Stein

  • 8 Posts
  • 0 Reply Likes
Hi all,

I have similar performance issues with 7.2. I didn't roll back yet but I've reset the preferences, optimized the catalog and followed all other hints that have been posted.

E.g. when I reject some images I instantly get the popup message that the images have been rejected, however they are not.

Also when I search for images sometime no results are being displayed. Even when I reset the filter no images come up until I restart lightroom.
Photo of John Whittington

John Whittington

  • 5 Posts
  • 1 Reply Like
Glad I'm not the only one. I went one further and did the nuclear option and completely reinstalled Windows, Lightroom, etc in case it was something else. And after all that, it's still running like a snail. And when it's doing something it hogs CPU from everything else so they run like a snail too. Been putting up with this for weeks now - I think ample apportunity for all the necessary reindexing.

It's not that I've got a particularly slow system either - an i7 (albeit Sandy Bridge) Lenovo X220 with catalogue and previews on a SSD with plenty of free space. Originals are on an internal 1TB hard disk (ie no need for network or USB). RAM is 8GB which is supposed to be satisfactory. I'd consider upgrading RAM however due to my configuration this would involve throwing away the 8GB I've got and starting again so it's not a particularly cheap option and I'd be pretty unhappy if I did all this and got no appreciable performance improvement.

Performance is not an issue for any other app (including large Access databases) nor has been for past versions of Lightroom.

I've got 40,260 mostly photos (a few videos) in my collection and the catalogue file is 1.2GB in size. The previews folder is 12.5GB. Online sync is off. I have optimised numerous times to no avail. And I've followed the Adobe guidance re configurations for improved performance. OS is Windows 7.

So it looks like my only practical option is to go back to 7.1. I guess the only way is to do a full uninstall and re-install (which is a pity as I've now got a pristine configuration due to the system rebuild). Or are there other options?

Many thanks

John
Photo of Klaus Mohr

Klaus Mohr

  • 7 Posts
  • 3 Reply Likes
Thanks to Rick and Rikk for your suggestions. Unfortunately they didn't help.

What I did to fix LR 7.2:
LR 7.1 completely uninstalled, settings also deleted.
System restarted.
Reinstalled LR 7.2 via Creative Cloud.
Settings set manually.

What I've been working on after doing that: (library module, grid mode) 
Add titles, headings and descriptions
Edit keywords via the keyword list
So nothing complicated, no Develop.

What happened in LR:
During the first 15 minutes after the LR start, the program runs smoothly and at the speed familiar from version 7.1.
During the second quarter of an hour the reaction to ALL inputs slows down. Clicks on thumbnails react slowly. Sometimes it takes up to 15 seconds until a just clicked thumbnail becomes active.
In between I have the feeling that the thumbnail has not registered the mouse click at all, because nothing is moving at all. But then, after 5 to 15 seconds waiting time, it is activated after all.
Metadata changes then take place at the same snail's pace. Changes to operating panels, for example from metadata to keyword list, then take between 3 and 6 seconds. A felt eternity.

If I edit the metadata in grid mode for longer than 30 minutes, the screen starts to flicker. Seems to be the only action going really fast at this stage. The LR program window disappears for fractions of a second, the Explorer icons of the taskbar also disappear for fractions of a second, before rebuilding themselves afterwards. Just as with a Windows Explorer restart via the task manager.

The Keyword List filter works perfectly the first time I use it.  I have about 15,000 keywords in hierarchical order.
After repeated use, it is hardly possible to make an entry. The cursor hangs after 1 or 2 letters, no further input is possible, the mouse pointer disappears.
The search mask field is cleared after up to 30 seconds (!), the cursor flashes and indicates that the complete word has been entered.
Example
Enter in the search mask: "photography".
Appearance of the search mask: "p" (cursor disappears)
After up to 30 seconds: "photography" appears and the cursor flashes.

What else I have observed:
Lightroom's RAM usage starts with about 200 MB after startup. As soon as you switch between thumbnails, the RAM usage increases up to about 2 GB. If the metadata is processed, the LR RAM rises to around 2.5 GB. 
Once developing an image the RAM usage reaches between 4.5 and 7 GB, depending on the steps of develop.

I have to track all this in the Windows task manager, TAB DETAILS.
LR has disappeared from the PROCESSES tab about 15 seconds after program start!  After an indefinite time, LR appears again in the PROCESSES TAB at the top of the RAM ranking...

  • Below the part for the techies of Adobe - the System Info from LR help menu:  (hoping you can help)

Lightroom Classic version: 7.2 [ 1156743 ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.16299
Application architecture: x64
System architecture: x64
Logical processor count: 4
Processor speed: 2,9 GHz
Built-in memory: 16122,3 MB
Real memory available to Lightroom: 16122,3 MB
Real memory used by Lightroom: 4910,2 MB (30,4%)
Virtual memory used by Lightroom: 5853,2 MB
GDI objects count: 1312
USER objects count: 2879
Process handles count: 2048
Memory cache size: 1099,4MB
Internal Camera Raw revision: 894
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 1989MB / 8061MB (24%)
Camera Raw real memory: 2267MB / 16122MB (14%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1080
Input types: Multitouch: Yes, Integrated touch: Yes, Integrated pen: Yes, External touch: No, External pen: No, Keyboard: Yes

Graphics Processor Info: 
DirectX: NVIDIA GeForce 940MX (23.21.13.8813)



Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic CC
Library Path: D:\LIGHTROOM\LIGHTROOM Classic CC.lrcat
Settings Folder: C:\Users\Klaus Mohr\AppData\Roaming\Adobe\Lightroom

Installed Plugins: 
1) Any Tag
2) HDR Efex Pro 2
3) jf Metadata Presets
4) Photo Upload
5) PhotoShelter

Config.lua flags: None

Adapter #1: Vendor : 10de
Device : 134d
Subsystem : 39ce17aa
Revision : a2
Video Memory : 2020
Adapter #2: Vendor : 8086
Device : 5916
Subsystem : 39ce17aa
Revision : 2
Video Memory : 80
Adapter #3: Vendor : 1414
Device : 8c
Subsystem : 0
Revision : 0
Video Memory : 0
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Lautsprecher (Realtek High Definition Audio)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: 10.0x7
Direct2DEnabled: false
GL_ACCUM_ALPHA_BITS: 16
GL_ACCUM_BLUE_BITS: 16
GL_ACCUM_GREEN_BITS: 16
GL_ACCUM_RED_BITS: 16
GL_ALPHA_BITS: 0
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 2048
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 4
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: GeForce 940MX/PCIe/SSE2
GL_SHADING_LANGUAGE_VERSION: 4.60 NVIDIA
GL_STENCIL_BITS: 8
GL_VENDOR: NVIDIA Corporation
GL_VERSION: 4.6.0 NVIDIA 388.13
GPUDeviceEnabled: false
OGLEnabled: true
GL_EXTENSIONS: GL_AMD_multi_draw_indirect GL_AMD_seamless_cubemap_per_texture GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_bindless_texture GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compatibility GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_compute_shader GL_ARB_compute_variable_group_size GL_ARB_conditional_render_inverted GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_derivative_control GL_ARB_direct_state_access GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_ES3_1_compatibility GL_ARB_ES3_2_compatibility GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4 GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_gl_spirv GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader_int64 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_indirect_parameters GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multi_draw_indirect GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_parallel_shader_compile GL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_polygon_offset_clamp GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_query_buffer_object GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counter_ops GL_ARB_shader_atomic_counters GL_ARB_shader_ballot GL_ARB_shader_bit_encoding GL_ARB_shader_clock GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_storage_buffer_object GL_ARB_shader_subroutine GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_include GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_sparse_buffer GL_ARB_sparse_texture GL_ARB_spirv_extensions GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_filter_anisotropic GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transform_feedback_overflow_query GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXTX_framebuffer_mixed_formats GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset_clamp GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_shader_objects GL_EXT_separate_specular_color GL_EXT_shader_image_load_formatted GL_EXT_shader_image_load_store GL_EXT_shader_integer_mix GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback2 GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_vertex_attrib_64bit GL_EXT_window_rectangles GL_EXT_import_sync_object GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KHR_context_flush_control GL_KHR_debug GL_EXT_memory_object GL_EXT_memory_object_win32 GL_EXT_win32_keyed_mutex GL_KHR_parallel_shader_compile GL_KHR_no_error GL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_EXT_semaphore GL_EXT_semaphore_win32 GL_KTX_buffer_region GL_NV_alpha_to_coverage_dither_control GL_NV_bindless_multi_draw_indirect GL_NV_bindless_multi_draw_indirect_count GL_NV_bindless_texture GL_NV_blend_equation_advanced GL_NV_blend_equation_advanced_coherent GL_NV_blend_minmax_factor GL_NV_blend_square GL_NV_command_list GL_NV_compute_program5 GL_NV_conditional_render GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_float GL_NV_depth_clamp GL_NV_draw_texture GL_NV_draw_vulkan_image GL_NV_ES1_1_compatibility GL_NV_ES3_1_compatibility GL_NV_explicit_multisample GL_NV_fence GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4 GL_NV_gpu_program4 GL_NV_internalformat_sample_query GL_NV_gpu_program4_1 GL_NV_gpu_program5 GL_NV_gpu_program5_mem_extended GL_NV_gpu_program_fp64 GL_NV_gpu_shader5 GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_coverage GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object GL_NV_parameter_buffer_object2 GL_NV_path_rendering GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_query_resource GL_NV_query_resource_tag GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_shader_atomic_counters GL_NV_shader_atomic_float GL_NV_shader_atomic_int64 GL_NV_shader_buffer_load GL_NV_shader_storage_buffer_object GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_multisample GL_NV_texture_rectangle GL_NV_texture_rectangle_compressed GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_transform_feedback GL_NV_transform_feedback2 GL_NV_uniform_buffer_unified_memory GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_attrib_integer_64bit GL_NV_vertex_buffer_unified_memory GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render GL_NVX_gpu_memory_info GL_NVX_multigpu_info GL_NVX_nvenc_interop GL_NV_shader_thread_group GL_NV_shader_thread_shuffle GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum GL_WIN_swap_hint WGL_EXT_swap_control
Photo of John Whittington

John Whittington

  • 5 Posts
  • 1 Reply Like
Whilst I haven't gone into as much detailed investigation as Klaus (well done Klaus!) I can confirm that some of the things he has found are the same in my situation.

I get good speed at start up (haven't timed it but 15 minutes sounds about right) and a similar slow down after that.  And I get the screen flicker/rebuild (ie the LR screen disappears to show the wallpaper then comes back a second later) that he mentions.

I also get the increasing RAM usage, although it tends to peak at about 2.5GB in my 8GB system.

One thing I also get is that after shutdown of LR (ie after LR has shut all windows and primary running instance) my system runs very slow for few minutes.  So it seems there is a background process involved.

Hope this helps.

Klaus, have you gone back to 7.1?  If so, are you back to normal speeds?

Mods, I see this thread is marked as solved.  I think Klaus' note above (together with others having the same problem) suggests that it isn't... :-)
Photo of Klaus Mohr

Klaus Mohr

  • 7 Posts
  • 3 Reply Likes
John, yes I've gone back to 7.1 and had the same speed as experienced before.

Then I uninstalled LR completely and reinstalled 7.2 from scratch.
My first impression was: Fine, now it runs! Sad to say that this was only the very first impression, not lasting longer than one hour...

I agree with you that this problem is NOT SOLVED at all.
(Edited)
Photo of John Whittington

John Whittington

  • 5 Posts
  • 1 Reply Like
Thanks Klaus, I guess I'll have to rollback to 7.1 too.  I don't want to do so but 7.2 is effectively unusable for me.  First time I've had this problem with LR... :-(
Photo of Martin Hopf

Martin Hopf

  • 20 Posts
  • 12 Reply Likes
Maybe still wait some days... 7.3 will be released in the next few days. hopefully this solves the problem. I am also using 7.2 and it is a nightmare. It stops responding for seconds when editing images (spinning blue cursor...) and will eat up all RAM after half an hour or so :(
Photo of Klaus Mohr

Klaus Mohr

  • 7 Posts
  • 3 Reply Likes
Easter week is a perfect time for experiments - here in Costa Rica nobody works over Easter anyway...

And so I start a new solution attempt:

I change the settings of "Application Control" of "Kaspersky Internet Security".  I will add Lightroom to the exclusions so that the AV machine no longer examines LR.
Maybe that's the bad guy.

And to the mods: Please set the thread to Unsolved! Or what do you think is solved here?

Have a nice Easter week!
Photo of John Whittington

John Whittington

  • 5 Posts
  • 1 Reply Like
FYI - no Kapersky on my system, just MSE.

And you have a good Easter too!
Photo of Klaus Mohr

Klaus Mohr

  • 7 Posts
  • 3 Reply Likes
Well, I suspected that any version of Internet Security or AV software could slow Lightroom down.
This may still be the case, but it has not been confirmed in my system. Lightroom continues to sneak - despite Kaspersky being disabled.

I will now follow Martin Hopf's advice and wait for 7.3. 

There's only one remedy for this long: Just before your nerves begin to burst, stop LR and restart   :-)
(Edited)
Photo of Martin Hopf

Martin Hopf

  • 21 Posts
  • 14 Reply Likes
I have no virus sw except windows defender - still same problem as you have. It is a ryzen machine with ssd and 16GB :-(
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 225 Reply Likes
Hi Folks,

As Martin said, very soon we will release version 7.3 which should take care of this issue. Let me know how that works and thanks so much for your patience!

Rick
Photo of John Whittington

John Whittington

  • 5 Posts
  • 1 Reply Like
Thanks Rick, hopefully by that you mean you've identified the problem so a fix in 7.3 is likely.

In the meantime, this gives me a good reason to avoid using LR for a while... :-)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1494 Posts
  • 476 Reply Likes
Lightroom 7.3 is now available https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-7-3-is-now-available. I think this particular performance issue might be fixed. Please give the new release a try.