Lightroom: How to restore the default web gallery maximum of 500?

  • 1
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
I would like to be able to reset the web gallery maximum in LR5 to over 500. I shot a wedding with 550 images and have to send the clients 2 slideshows!
Photo of Heidi Long

Heidi Long

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
Have at look at this thread:
https://forums.adobe.com/thread/911179
Photo of Heidi Long

Heidi Long

  • 6 Posts
  • 0 Reply Likes
Steve:

I had viewed that thread but it doesn't appear to be applicable to LR5. When I contacted Adobe tech support they said there is no way to reset this value in LR5-thus the frustration. Thanks for your help tho.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3823 Posts
  • 1266 Reply Likes
It still works in LR5 - I tested it when I updated my book for LR5 and just tested it again.

Windows:
1. Find the following folder: C:\Program Files\Adobe\Adobe Photoshop Lightroom 5.x\shared\webengines\default_flash. lrwebengine\
2. Copy that default_flash.lrwebengine folder to your user Web Galleries folder. You may have to create the Web Galleries folder at:C:\Users\[your username]\AppData\Roaming\Adobe\ Lightroom\Presets\Web Galleries\
3. Ensure that you have read/write access to the folder and files.
4. Inside that folder is a file called galleryInfo.lrweb, which you need to open in a basic text editor such as Notepad.
5. Find the line that says “maximumGallerySize=500,” and increase the value.
6. Save and close the file.
7. Restart Lightroom and check that your gallery will now allow larger numbers of photos.

Mac:
1. Go to the Applications folder
2. Right-click on Adobe Photoshop Lightroom 5.app and select ‘Show Package Contents’
3. Navigate to Contents > Plug-ins > Web.lrmodule
4. Right-click on Web.lrmodule and select ‘Show Package Contents’
5. Navigate to Contents > Resources > Galleries
6. Copy that default_flash.lrwebengine folder to your user web galleries folder. You may have to create the Web Galleries folder at: Macintosh HD/Users/[your username]/Library/Application Support/Adobe/Lightroom/Presets/Web Galleries/
7. Ensure that you have read/write access to the folder and files.
8. Inside that folder is a file called galleryInfo.lrweb, which you need to open in a basic text editor such as TextEdit.
9. Find the line that says “maximumGallerySize=500,” and increase the value.
10. Save and close the file
11. Restart Lightroom and check that your gallery will now allow larger numbers of photos.

John's note in that thread about updating the title and id still works too, if you want the gallery to show up separately.
Photo of Heidi Long

Heidi Long

  • 6 Posts
  • 0 Reply Likes
Victoria! It worked!

For whatever reason the library folder didn't show up under my user name until I went thru Lightroom>preferences>Presets>show presets folder. Then "Library" came up but the name was screened back-weird.

Anyway the rest of your path was smack on except there was no single "presets" folder. Library>Application Support>Adobe>Lightroom>Web Galleries then after copying the default_flash.lrwebengine I had to right click to "show package contents" then open galleryinfo.lrweb

I never would've figured this out on my own in a million years. Thank you so much.
Photo of fastasleep

fastasleep

  • 1 Post
  • 0 Reply Likes
Heidi — Go to your home folder (user name) and View > Show View Options > Show Library Folder

Details: http://www.macworld.com/article/20572...