Rendering of image assets lower quality than expected, and not matching equivalents from 'Save for Web'

  • 1
  • Problem
  • Updated 3 years ago
I'm finding the image quality of generated assets is significantly poorer than expected, particularly when it comes in compression artefacts on JPEGs and also how things like text is rendered. Wondering if I'm alone in this experience. Examples below (you will have to open the image in a new tab at 100% for full effect):

Image exported via 'Save for Web (Legacy)':

The image above was saved as a JPEG: Quality 90, Blur 0, Optimised, Embedded Color Profile, sRGB with Bicubic sizing.

Image exported via Adobe Generator

The image above was exported via generator with the default settings.

Note the poor text rendering (the right of the last 0 is clipped off) and the compression artefacts, particularly around the lettering and logo. I'm also wondering about the differences in colour/profile.

Significant difference in file size too.

Here are the results with quality set to jpg8 / 80%:

Image exported via 'Save for Web (Legacy)' 80% quality:

Image exported via Adobe Generator jpg8:

And here is probably the worst example, the 32-bit PNG. Both should be identical, or so I would have thought:

Image exported via 'Save for Web (Legacy)' PNG 32:

Image exported via Adobe Generator PNG:

Not really usable as a viable method of generating assets for the web if these are the results.
Photo of Jim Collinson

Jim Collinson

  • 5 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1

Be the first to post a reply!