Lightroom 6.2: Remove Chromatic Aberration bug

  • 12
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
I’ve just discovered a bug in the Develop Module in LR6.2 perpetual version. I have Photoshop CS6 perpetual updated as far as it will go (to ACR 9.1), Mac.

I’ve not been affected by the changes to Import in LR6.2 which are causing many people so much stress, as I always copy files from the card to the computer drive before importing and do all my in initial file organisation outside of LR and apply all metadata after import.

I set my default develop parameters by hitting alt-Reset in the Develop Module and I have these set in LR prefs as “specific to camera serial number”. My default setting are actually very close to the LR defaults except I tend to add a little Vibrance, turn off sharpening and I always have “Remove Chromatic Aberration” checked. However, since updating to 6.2, newly imported files do not have the CA tick box checked although all other settings that I have tried appears to be as they should be. Strangely, when I then hit the Reset button (which restores the Develop defaults), the CA button then gets checked. This is odd behaviour as it should be checked after import.

I then tried saving my default settings as a User Preset and applying that in the Import Dialogue and I get the same thing - the CA button is not checked although, once again, hitting the Reset button checks it. So LR is not applying all the default settings properly upon import. However, when I open a raw image (with no sidecar XMP file) in ACR 9.1, the CA button is checked as it should be. I’ve tested this out with raw files from several different Nikon cameras (Nikon NEFs).

Now remove CA is very important in raw file conversions and the fact that it isn't checked could be easily missed. I would hate to have to go back to a large batch of files if I’d worked on the converted images and then found that CA was not removed. That could involve a lot of wasted time. Basically the workaround is to import (either using defaults in the Develop Module or applying a Develop Preset in the Import Dialogue), select a file, hit Reset (which applies all the default settings including remove CA) and then sync all other newly imported files.

I’m wondering if anybody else is experiencing this. I've searched this forum and not found anything. Is it universal to all LR users since this latest update?
Photo of MDM

MDM

  • 5 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 12
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1635 Posts
  • 550 Reply Likes
Thanks for the report. I can confirm that it is a bug introduced in Lr 6.2 and I've submitted a fix for the next Lr update (6.3).
Photo of MDM

MDM

  • 5 Posts
  • 0 Reply Likes
Great thanks Simon. I'm glad it's been acknowledged and will be fixed I'm sure in the next update. I discovered it quite by accident and have not seen anything about it elsewhere.

It's such an excellent feature of LR and ACR - it really does the job on lateral CA and I don't examine images any more for CA because of that. Once it's set as a default, I don't tend to look at it again because of where it sits in the Develop Module, so it would be possible to process a lot of images before realising it wasn't set. I only saw it because I took some architectural shots yesterday (which I don't usually do) and went into the Lens Correction section to correct converging verticals when I noticed it wasn't ticked.
Photo of Kaffeesegler

Kaffeesegler

  • 43 Posts
  • 22 Reply Likes
This reply was created from a merged topic originally titled Not all parameters from a develop preset are used after the new import dialog.

When I import using a develop preset forcing the develop process to switch CA to "on" LR does not set this switch for the importet pictures but shows all importes pictures with the switch in position off. I have to enable CA after the import for all pictures manually
Photo of William White

William White

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled LIGHTROOM 6.2 - Chromatic Aberration setting not being applied during image impor....

When importing images using my develop preset, the chromatic aberration setting is not being applied. This occurred after upgrading to ver. 6.2.
Photo of Jeremy Whigham

Jeremy Whigham

  • 14 Posts
  • 0 Reply Likes
Same problem here
Photo of Carlos Oliveras

Carlos Oliveras

  • 137 Posts
  • 32 Reply Likes
Same problem too. Hoping for a fix, I always apply "Remove CA" via a preset on import, and it wasn't until another person brought this issue to my attention that I realised that all my previosly imported raws (since LR 2015.2) didn't had the "Remove CA" option checked as I thought!!
But at least I have this wonderful new import screen. That totally makes up for it... (just joking...).
Thanks in advance for fixing it.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15633 Posts
  • 2368 Reply Likes
Official Response
This is fixed in Lightroom 2015.4/6.4 or later.