Lightroom 6.2: Remove Chromatic Aberration bug

  • 12
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)
I’ve just discovered a bug in the Develop Module in LR6.2 perpetual version. I have Photoshop CS6 perpetual updated as far as it will go (to ACR 9.1), Mac.

I’ve not been affected by the changes to Import in LR6.2 which are causing many people so much stress, as I always copy files from the card to the computer drive before importing and do all my in initial file organisation outside of LR and apply all metadata after import.

I set my default develop parameters by hitting alt-Reset in the Develop Module and I have these set in LR prefs as “specific to camera serial number”. My default setting are actually very close to the LR defaults except I tend to add a little Vibrance, turn off sharpening and I always have “Remove Chromatic Aberration” checked. However, since updating to 6.2, newly imported files do not have the CA tick box checked although all other settings that I have tried appears to be as they should be. Strangely, when I then hit the Reset button (which restores the Develop defaults), the CA button then gets checked. This is odd behaviour as it should be checked after import.

I then tried saving my default settings as a User Preset and applying that in the Import Dialogue and I get the same thing - the CA button is not checked although, once again, hitting the Reset button checks it. So LR is not applying all the default settings properly upon import. However, when I open a raw image (with no sidecar XMP file) in ACR 9.1, the CA button is checked as it should be. I’ve tested this out with raw files from several different Nikon cameras (Nikon NEFs).

Now remove CA is very important in raw file conversions and the fact that it isn't checked could be easily missed. I would hate to have to go back to a large batch of files if I’d worked on the converted images and then found that CA was not removed. That could involve a lot of wasted time. Basically the workaround is to import (either using defaults in the Develop Module or applying a Develop Preset in the Import Dialogue), select a file, hit Reset (which applies all the default settings including remove CA) and then sync all other newly imported files.

I’m wondering if anybody else is experiencing this. I've searched this forum and not found anything. Is it universal to all LR users since this latest update?
Photo of MDM

MDM

  • 5 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 12
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13968 Posts
  • 1664 Reply Likes
Official Response
This is fixed in Lightroom 2015.4/6.4 or later.